Bug 625354 - SELinux is preventing /bin/login "create" access on root.
SELinux is preventing /bin/login "create" access on root.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b5af99f3538...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 03:16 EDT by Joachim Frieben
Modified: 2010-09-23 08:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.9.3-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 05:08:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2010-08-19 03:16:16 EDT
Summary:

SELinux is preventing /bin/login "create" access on root.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by login. It is not expected that this access is
required by login and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_run_t:s0
Target Objects                root [ dir ]
Source                        login
Source Path                   /bin/login
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           util-linux-ng-2.18-3.fc14
Target RPM Packages           filesystem-2.4.35-1.fc14
Policy RPM                    selinux-policy-3.8.8-14.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.2-9.fc14.x86_64 #1 SMP Tue Aug
                              17 22:36:15 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 18 Aug 2010 08:03:38 PM CEST
Last Seen                     Wed 18 Aug 2010 08:03:38 PM CEST
Local ID                      36175526-b2b1-4ddb-b405-9decaabd69eb
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282154618.186:19): avc:  denied  { create } for  pid=1722 comm="login" name="root" scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1282154618.186:19): arch=c000003e syscall=83 success=yes exit=0 a0=1254880 a1=1c0 a2=0 a3=64 items=0 ppid=1 pid=1722 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=tty2 ses=1 comm="login" exe="/bin/login" subj=system_u:system_r:local_login_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,login,local_login_t,var_run_t,dir,create
audit2allow suggests:

#============= local_login_t ==============
allow local_login_t var_run_t:dir create;
Comment 1 Daniel Walsh 2010-08-23 13:34:39 EDT
Is your /root directory labeled var_run_t?

ls -lZd /root
Comment 2 Joachim Frieben 2010-09-02 00:51:30 EDT
> ls -lZd /root
dr-xr-x---. root root system_u:object_r:admin_home_t:s0 /root/

Attributes stemming from selinux-policy-targeted-3.9.1-2.fc14. After the update, filesystems have been fully relabeled.
Comment 3 Daniel Walsh 2010-09-02 11:48:08 EDT
Ok this is caused by a change in systemd.

You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.9.2-1.fc14
Comment 4 Fedora Update System 2010-09-10 12:49:14 EDT
selinux-policy-3.9.3-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.3-4.fc14
Comment 5 Fedora Update System 2010-09-10 22:17:07 EDT
selinux-policy-3.9.3-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.3-4.fc14
Comment 6 Fedora Update System 2010-09-23 08:40:56 EDT
selinux-policy-3.9.3-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.