Bug 62536 - hotplug RPM out of date and buggy
hotplug RPM out of date and buggy
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 03:31 EST by Landon Curt Noll
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 03:31:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2002-04-02 03:31:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The hotplug RPM supplied by RH7.2 is very out
of date and is buggy.

A number of USB devices, such as Philips and Logitech web cams
(via the pwc driver) will not hotplug due to numerious problems
with this out of date package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -q hotplug
2.with the PWC USB module configured, plug in a Philips 730 /
Logitech 3000 Pro web camera
3.
	

Actual Results:  hotplug fails to function, even with a /etc/hotplug/usb/pwc install
mod script in place.

Given the problems with the old hotplug software, I suspect many
other USB devices will fail to hotplug.

Expected Results:  The camera and modules install when the USB camera is installed.
Other registered USB devices should also hotplug.

Additional info:

To get most USB devices to work, one needs:

hotplug-2002-04-01-1 (see
http://prdownloads.sourceforge.net/linux-hotplug/hotplug-2002_04_01-1.noarch.rpm)
hwdata-0.8.3
usbutils-0.9.5

The hwdata and usbutils are found in the RH 7.2.92 Beta i386
release, but the hotplug is sill out of date.

When hotplug-2002-04-01-1, hwdata-0.8.3 and usbutils-0.9.5 RPMs
are installed on a up to date RH7.2, things work.
For example, placing the following script:

#!/bin/bash
#
# Phillips webcam module setup
#
/usr/bin/logger -p daemon.notice -t hotplug/usb/pwc -i Phillips webcam setup
/sbin/modprobe pwc
if [ -f /etc/hotplug/usb/pwcx-i386.o ]; then
    /usr/bin/logger -p daemon.notice -t hotplug/usb/pwc -i pwcx-i386.o insmod
    /sbin/insmod --force /etc/hotplug/usb/pwcx-i386.o >/dev/null 2>&1
fi
/usr/bin/logger -p daemon.notice -t hotplug/usb/pwc -i Phillips webcam complete

is placed in /etc/hotplug/usb/pwc, and the pwc module is configured
in the kernel, the camera hotplugs.

I recommend that RH update RH7.2 with hotplug-2002-04-01-1,
hwdata-0.8.3 and usbutils-0.9.5.  I also recommened that it
update hotplug in the beta release.
Comment 1 Trond Eivind Glomsrxd 2002-04-02 11:47:03 EST
This is not a problem. I have one of those cams, and they work fine. The old
version is not known to be particularly buggy.


(that said, it was updated yesterday, but that has nothing to do with this bogus
report)

Note You need to log in before you can comment on or make changes to this bug.