Bug 625371 - btrfs: fsstress would be stuck on hp-dl120g6-01.rhts.eng.bos.redhat.com
btrfs: fsstress would be stuck on hp-dl120g6-01.rhts.eng.bos.redhat.com
Status: CLOSED DUPLICATE of bug 663749
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Josef Bacik
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 04:14 EDT by Eryu Guan
Modified: 2011-02-01 13:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 13:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fsstress stuck backtrace and sysrq-w state (197.44 KB, text/plain)
2010-09-09 04:14 EDT, Eryu Guan
no flags Details

  None (edit)
Description Eryu Guan 2010-08-19 04:14:26 EDT
Description of problem:
fsstress running on nfs using btrfs as the backend fs would be stuck on host hp-dl120g6-01.rhts.eng.bos.redhat.com. 
This is not a regression and only happens on host hp-dl120g6-01.rhts.eng.bos.redhat.com(or I only found failure on this host).

Version-Release number of selected component (if applicable):
kernel-2.6.32-66.el6.x86_64
also kernel-2.6.32-59.el6.x86_64

How reproducible:
always

Steps to Reproduce:
run /kernel/filesystems/btrfs/fsstress on host hp-dl120g6-01.rhts.eng.bos.redhat.com
  
Actual results:
https://beaker.engineering.redhat.com/logs/2010/86/12886/24409/306293/878639///console_dmesg--kernel-filesystems-btrfs-fsstress-avc.log

Expected results:
Pass the test

Additional info:
I tried fsstress on btrfs partition directly(without nfs) and test passed.
Comment 2 Eric Sandeen 2010-09-08 11:56:08 EDT
Josef can you take a look?
Comment 3 Josef Bacik 2010-09-08 16:23:40 EDT
The backtraces aren't very informative, can I get a sysrq+w?  And are we sure we're actually hung and not just taking forever to finish?  There have been cases where sync writeback was pretty crappy and taking forever, but eventually finished.  Thanks,

Josef
Comment 4 Eryu Guan 2010-09-08 23:19:16 EDT
The fsstress itself was finished eventually and passed, just with these annoying messages showed up. I'll get sysrq+w as soon as I get the host.
Comment 5 Eryu Guan 2010-09-09 04:14:16 EDT
Created attachment 446162 [details]
fsstress stuck backtrace and sysrq-w state

I attached the full sysrq-w log when got stuck. Hope this can help.
Comment 6 Josef Bacik 2010-09-10 09:02:17 EDT
How are you running fsstress btw?  And how exactly is this setup, are you exporting the NFS volume from a different machine or the same machine?  Have you tried to reproduce this on NFS with an ext4 backend to see if it's just NFS related?  I'm trying the fsstress test from xfs and I'll see how that works, but it would be good to be running the same fsstress command as you.
Comment 7 Eryu Guan 2010-09-10 22:51:02 EDT
That's reasonable. I'll try more cases(ext4 backend, ext4 without nfs).
It's a locally exported loop device.
Comment 8 Eryu Guan 2010-09-29 04:45:19 EDT
Sorry for the late reply.

I tried different configurations, and the results are:
(NFS exports with rw,fsid=0,insecure,no_subtree_check,sync,no_root_squash)

Use NFS    NFS mount option    [Backend] FS    Stuck
yes        -o hard,intr [0]    btrfs           Yes
yes        ----                btrfs           No [1]
yes        -o hard,intr        ext4            ?? [2]
yes        ----                ext4            No
no         ----                btrfs           No
no         ----                ext4            No

[0] The hard option is default on for NFS
[1] No stuck found, but got "NFS: file server not responding: still trying. " from console
[2] I'll try this once I get the host again.
Comment 9 Eryu Guan 2010-09-29 23:12:39 EDT
(In reply to comment #8)

> I tried different configurations, and the results are:
> (NFS exports with rw,fsid=0,insecure,no_subtree_check,sync,no_root_squash)
> 
> Use NFS    NFS mount option    [Backend] FS    Stuck
> yes        -o hard,intr [0]    btrfs           Yes
> yes        ----                btrfs           No [1]
> yes        -o hard,intr        ext4            ?? [2]

Confirmed mount nfs with -o hard,intr and ext4 as backend fs can pass the test.
Run fsstress with -d testdir -p 200 -n 100
Comment 10 RHEL Product and Program Management 2011-01-06 23:30:42 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 11 Suzanne Yeghiayan 2011-01-07 11:15:03 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 12 RHEL Product and Program Management 2011-02-01 01:00:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 RHEL Product and Program Management 2011-02-01 13:34:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 14 Josef Bacik 2011-02-01 13:42:55 EST
Should be fixed in the backport of btrfs.

*** This bug has been marked as a duplicate of bug 663749 ***

Note You need to log in before you can comment on or make changes to this bug.