Bug 625396 - virt-manager remote vnc terminal fails when remote user not using bash as shell
Summary: virt-manager remote vnc terminal fails when remote user not using bash as shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-19 10:18 UTC by Alan
Modified: 2010-09-04 04:59 UTC (History)
5 users (show)

Fixed In Version: virt-manager-0.8.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-04 04:59:21 UTC


Attachments (Terms of Use)

Description Alan 2010-08-19 10:18:30 UTC
Description of problem:
Using console under virt-manager fails when connected to a remote qemu+ssh host whose user has a default shell that fails to accept bash error-redirection syntax

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-2.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1.  create a libvirtd server containing a vm and a user with tcsh as a default shell
2.  use virt-manager gui (gtk) to connect to that server remotely via qemu+ssh://user@host
3.  attempt to launch console
  
Actual results:
Error:  VNC connection to hypervisor host got refused or disconnected!
Error:  Ambiguous output redirect

Expected results:
vnc connection is made without issue

Additional info:
this seems to be a result of 7 lines of code starting in line 517 of console.py in /usr/share/virt-manager/virtManager which attempts to execute a remote "nc" command.  The code in there is using bash syntax without ever calling a bash interpreter.  if the remote user has a shell that doesn't use the 2>&1 error redirection syntax the program exits with the above error.
changing the remote user shell to /bin/bash made the problem disappear.  looks like the nc code in there was put in as a bit of a kludge anyway, should be easy enough to specify a command interpreter for the shell call, but I don't know enough about python or how virt-manager works to submit an actual patch...

Comment 1 Cole Robinson 2010-08-19 13:31:06 UTC
What shell are you using on the remote machine?

Comment 2 Alan 2010-08-19 19:50:29 UTC
tcsh

Comment 3 Cole Robinson 2010-08-23 20:41:53 UTC
I believe this is fixed now upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/16fcbf77e47e

Comment 4 Fedora Update System 2010-08-25 20:58:49 UTC
virt-manager-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

Comment 5 Fedora Update System 2010-08-26 00:53:12 UTC
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

Comment 6 Alan 2010-08-31 00:13:20 UTC
hummm...I can't seem to get the update.  the yum command failed to find it and when I look manually it isn't in:
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/13/x86_64/
I also checked i386 just in case....
-alan

Comment 7 Cole Robinson 2010-08-31 12:31:31 UTC
Hmm, not sure what happened, I've pushed to testing now, it should show up in the next few days.

Comment 8 Fedora Update System 2010-09-01 03:27:34 UTC
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

Comment 9 Alan 2010-09-01 20:59:29 UTC
ok,
virt-manager-0.8.5-1.fc13
seems to have fixed the problem.  thanks
-alan

Comment 10 Fedora Update System 2010-09-04 04:58:45 UTC
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.