Bug 625428 - libvirt hangs if qemu-kvm dies while dumping core
libvirt hangs if qemu-kvm dies while dumping core
Status: CLOSED DUPLICATE of bug 531983
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 08:14 EDT by David Juran
Modified: 2010-12-29 05:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-29 05:11:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2010-08-19 08:14:36 EDT
Description of problem:
If the qemu-kvm process would die while running "virsh dump", libvirtd(?)
 will hang and no further actions can be perfomed.

Version-Release number of selected component (if applicable):
libvirt-0.6.3-33.el5_5.3

How reproducible:
Every time

Steps to Reproduce:
1. virsh dump eldin /tmp/dump
2. while the above is running, run "kill $(pidof qemu-kvm)"
3.  Now try e.g. "virsh list"
  
Actual results:
virsh list hangs

Expected results:
virsh list works
Comment 1 hiroshi.itani 2010-10-08 06:07:01 EDT
Maybe this problem is the same
Comment 2 hiroshi.itani 2010-10-08 06:09:33 EDT
bug 531983(In reply to comment #1)

The same bug 531983
Comment 3 David Juran 2010-12-29 05:11:14 EST
Sounds reasonable, at least libvirt-0.8.2-15.el5 solves the problem.

*** This bug has been marked as a duplicate of bug 531983 ***

Note You need to log in before you can comment on or make changes to this bug.