Bug 625430 - V2V fails to install virtio_net and virtio_blk to Win2k3(32bit and 64bit)
V2V fails to install virtio_net and virtio_blk to Win2k3(32bit and 64bit)
Status: CLOSED DUPLICATE of bug 615981
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 08:15 EDT by Rita Wu
Modified: 2013-07-02 21:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 11:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from LIBGUESTFS_TRACE=1 (3.01 KB, application/octet-stream)
2010-08-19 08:15 EDT, Rita Wu
no flags Details

  None (edit)
Description Rita Wu 2010-08-19 08:15:48 EDT
Created attachment 439663 [details]
log from LIBGUESTFS_TRACE=1

Description of problem:
It happens on Win2k3 with all hypervisors(Xen,KVM and ESX). Even the Win2k3-64bit guest with the size of 10G. 

In Win2k3 guest:
1. virtio drivers have copied to /windows/drivers/virtio
2. the value in DevicePath from registry is  %SystemRoot%\inf;%SystemRoot%\Drivers/VirtIO 


Version-Release number of selected component (if applicable):
virt-v2v-0.6.2-3.el6.x86_64
libguestfs-winsupport-1.0-5.el6.x86_64
libguestfs-1.2.7-1.23.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.convert Win2k3 sp2 guests
  
Actual results:
V2V fails to install virtio_net and virtio_blk to Win2k3(32bit and 64bit) 

Expected results:
install virtio_net and virtio_blk to Win2k3(32bit and 64bit)  successfully.

Additional info:
win2k3-64bit guest's log from virt-inspector 
$VAR1 = '/dev/sda1';
$VAR2 = {
          'arch' => 'x86_64',
          'apps' => [],
          'os' => 'windows',
          'major_version' => '5',
          'root_device' => '/dev/sda1',
          'filesystems' => {
                             '/dev/sda1' => {
                                              'arch' => 'x86_64',
                                              'windows_registered_owner' => 'rhqe',
                                              'content' => 'windows-root',
                                              'is_root' => 1,
                                              'windows_current_type' => 'Uniprocessor Free',
                                              'windows_system_hive' => '/WINDOWS/system32/config/system',
                                              'os_minor_version' => '2',
                                              'fsos' => 'windows',
                                              'systemroot' => '/WINDOWS',
                                              'windows_software_hive' => '/WINDOWS/system32/config/software',
                                              'windows_software_type' => 'SYSTEM',
                                              'windows_registered_organization' => 'REDHAT',
                                              'windows_current_build' => '1.511.1 () (Obsolete data - do not use)',
                                              'is_mountable' => 1,
                                              'os_major_version' => '5',
                                              'boot_ini' => '/boot.ini',
                                              'fstype' => 'ntfs',
                                              'product_name' => 'Microsoft Windows Server 2003'
                                            }
                           },
          'root' => $VAR2->{'filesystems'}{'/dev/sda1'},
          'minor_version' => '2',
          'mounts' => {
                        '/' => '/dev/sda1'
                      },
          'product_name' => 'Microsoft Windows Server 2003'
        };
Comment 1 Rita Wu 2010-08-19 08:20:48 EDT
BTW, Manually "Update Driver" from "Device Manager" doesn't work.
Although it won't install virtio_blk driver, Win2k3 won't BSOD.For win2k3 has another SCSI driver with unknown signature.  Due to virtio_net doesn't be installed, so guest cannot get IP.
Comment 4 Matthew Booth 2010-08-19 11:18:26 EDT
This is a bug in the fix for bug 615981.

*** This bug has been marked as a duplicate of bug 615981 ***

Note You need to log in before you can comment on or make changes to this bug.