Bug 625464 - No network: nm-applet doesn't show up, complains about d-bus
No network: nm-applet doesn't show up, complains about d-bus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 10:10 EDT by Horst H. von Brand
Modified: 2010-08-31 09:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 09:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2010-08-19 10:10:16 EDT
Description of problem:
Since yesterday's updates (20100818) nm-applet doesn't show up, and the network doesn't work. Neither WiFi (set up to connect automatically) nor eth0 (static configuration for my account). Luckily I still remember how to configure eth0 by hand :-/

Running the following ($ ~~-> me, # ~~-> root):

$nm-applet
An instance of nm-applet is already running.

** (nm-applet:3606): WARNING **: <WARN>  constructor(): Couldn't initialize the D-Bus manager.

# nmcli dev status

** (process:4050): WARNING **: nm_client_get_devices: error getting devices: Unit NetworkManager-by-dbus.service failed to load. See logs for details.

DEVICE     TYPE              STATE       

Last line of /var/log/messages is:

Aug 19 10:04:27 laptop14 kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument

Version-Release number of selected component (if applicable):
dbus-1.3.2-0.1.885483.fc15.x86_64
kernel-2.6.36-0.0.rc0.git1.fc15.x86_64
NetworkManager-0.8.1-4.git20100817.fc15.x86_64

How reproducible:
Happened yesterday at home (WiFi) now here at work (eth0)

Steps to Reproduce:
1. Boot...
2.
3.
  
Actual results:
No network, no nm-applet icon

Expected results:
Network working normally

Additional info:
Comment 1 Lennart Poettering 2010-08-19 10:46:59 EDT
Yupp, NM doesn't enable it's unit files properly. dcbw already prepared a fix for this. Reassigning to NM in meantime.
Comment 2 Horst H. von Brand 2010-08-31 09:41:52 EDT
It works now. Closing.

Note You need to log in before you can comment on or make changes to this bug.