Bug 62548 - pause when su-ing from nobody with pam-0.75-18.7
pause when su-ing from nobody with pam-0.75-18.7
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 09:12 EST by Steve Mellor
Modified: 2013-07-02 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 15:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Mellor 2002-04-02 09:12:49 EST
Description of problem:

su hangs for approx 20 sec when su-ing from nobody.

no hang if pam_xauth.so is commented out of /etc/pam.d/su
no hang if you su from any other user than nobody


Version-Release number of selected component: pam-0.75-18.7

How reproducible: Always

Steps to Reproduce:

1. update pam to pam-0.75-18.7  (the fix for RHBA-2001:149-14)
2. from a root login: 'su - nobody'
3. su - <a user>

once the password is entered there is a 20 sec delay before the su command
completes. strace on the 'su' shows :

[snip]
read(3, "root:x:0:0:root:/root:/bin/bash\n"..., 4096) = 4096
close(3)                                = 0
munmap(0x40022000, 4096)                = 0
getgid32()                              = 99
getuid32()                              = 99
pipe([3, 4])                            = 0
pipe([5, 6])                            = 0
fork()                                  = 24264
close(3)                                = 0
close(6)                                = 0
close(4)                                = 0
read(5,

<20 seconds delay>

 "", 2048)                       = 0
--- SIGCHLD (Child exited) ---
close(5)                                = 0
wait4(24264, NULL, 0, NULL)             = 24264
fork()                                  = 24265
rt_sigprocmask(SIG_BLOCK, ~[], NULL, 8) = 0
rt_sigaction(SIGTERM, {0x80498c0, [], 0x4000000}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [ALRM TERM], NULL, 8) = 0
wait4(-1,
Comment 1 Jindrich Novy 2004-10-03 15:15:20 EDT
[root@localhost root]#su - nobody
This account is currently not available.

Looks like there's no more possible to log in as nobody.

Note You need to log in before you can comment on or make changes to this bug.