Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625483 - Permission issue w/ pulp log files when using pulp-admin
Permission issue w/ pulp log files when using pulp-admin
Status: CLOSED DUPLICATE of bug 621680
Product: Pulp
Classification: Retired
Component: z_other (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 11:13 EDT by dgao
Modified: 2011-07-15 15:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 14:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dgao 2010-08-19 11:13:25 EDT
Description of problem:
There's a permission issue with /var/log/pulp if pulp-admin is immediately executed after a fresh rpm install. The folder, and subsequently all the pulp log files are owned by root with permission of 644. As a result, pulp-admin fails. 

[dgao@pulp ~]$ pulp-admin -u admin -p admin repo list
ERROR: must be root to execute
[dgao@pulp ~]$ su - 
Password: 
[root@pulp ~]# pulp-admin -u admin -p admin repo list
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
 root@pulp and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.2.16 (Fedora) Server at localhost Port 8811</address>
</body></html>

[root@pulp ~]# 
[root@pulp ~]# ls -larth /var/log/pulp
total 12K
drwxr-xr-x. 16 root root 4.0K Aug 19 11:04 ..
drwxr-xr-x.  2 root root 4.0K Aug 19 11:04 .
-rw-r--r--.  1 root root 1.9K Aug 19 11:10 pulptools.log

[root@pulp ~]# tail /var/log/httpd/pulp_webservices.error 
[Thu Aug 19 11:10:00 2010] [error] [client ::1]   File "/usr/lib/python2.6/site-packages/pulp/webservices/application.py", line 51, in wsgi_application
[Thu Aug 19 11:10:00 2010] [error] [client ::1]     start_logging()
[Thu Aug 19 11:10:00 2010] [error] [client ::1]   File "/usr/lib/python2.6/site-packages/pulp/logs.py", line 98, in start_logging
[Thu Aug 19 11:10:00 2010] [error] [client ::1]     configure_pulp_grinder_logging()
[Thu Aug 19 11:10:00 2010] [error] [client ::1]   File "/usr/lib/python2.6/site-packages/pulp/logs.py", line 50, in configure_pulp_grinder_logging
[Thu Aug 19 11:10:00 2010] [error] [client ::1]     check_log_file(pulp_file)
[Thu Aug 19 11:10:00 2010] [error] [client ::1]   File "/usr/lib/python2.6/site-packages/pulp/logs.py", line 33, in check_log_file
[Thu Aug 19 11:10:00 2010] [error] [client ::1]     raise RuntimeError('Cannot write to log directory: %s' % dir_path)
[Thu Aug 19 11:10:00 2010] [error] [client ::1] RuntimeError: Cannot write to log directory: /var/log/pulp
[Thu Aug 19 11:10:00 2010] [info] [client ::1] Connection closed to child 6 with standard shutdown (server 127.0.0.1:8811)
[root@pulp ~]#
Comment 1 Preethi Thomas 2010-08-19 14:13:27 EDT
looks like its similar to the issue in
https://bugzilla.redhat.com/show_bug.cgi?id=621680
Comment 2 Preethi Thomas 2010-08-19 14:43:31 EDT

*** This bug has been marked as a duplicate of bug 621680 ***

Note You need to log in before you can comment on or make changes to this bug.