Bug 625512 - Error in PREUN scriptlet in rpm package gpm /var/tmp/rpm-tmp.djTM0L: line 8: syntax error: unexpected end of file error: %preun(gpm-1.20.6-10.fc14.x86_64) scriptlet failed, exit status 2
Summary: Error in PREUN scriptlet in rpm package gpm /var/tmp/rpm-tmp.djTM0L: line 8: ...
Status: CLOSED DUPLICATE of bug 624253
Alias: None
Product: Fedora
Classification: Fedora
Component: gpm   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nikola Pajkovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F14Target
TreeView+ depends on / blocked
 
Reported: 2010-08-19 17:10 UTC by Nicolas Mailhot
Modified: 2014-02-02 22:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 12:06:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2010-08-19 17:10:14 UTC
Updating       : gpm-libs-1.20.6-11.fc14.x86_64                                                                                                               6/74 
Updating       : gpm-1.20.6-11.fc14.x86_64                                                        
                                                            7/74 

...
Error in PREUN scriptlet in rpm package gpm
/var/tmp/rpm-tmp.djTM0L: line 8: syntax error: unexpected end of file
error: %preun(gpm-1.20.6-10.fc14.x86_64) scriptlet failed, exit status 2

Comment 1 Nicolas Mailhot 2010-08-19 17:11:05 UTC
...
gpm-1.20.6-10.fc14.x86_64 was supposed to be removed but is not!


yum-3.2.28-3.fc14.noarch
rpm-4.8.1-5.fc14.x86_64

Comment 2 Nicolas Mailhot 2010-08-19 17:13:55 UTC
# LANG=C package-cleanup --cleandupes
Loaded plugins: refresh-packagekit
--> Running transaction check
---> Package gpm.x86_64 0:1.20.6-10.fc14 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package Arch       Version              Repository                       Size
===============================================================================
Removing:
 gpm     x86_64     1.20.6-10.fc14       @/gpm-1.20.6-10.fc14.x86_64     396 k

Transaction Summary
===============================================================================
Remove        1 Package(s)

Installed size: 396 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREUN scriptlet in rpm package gpm
gpm-1.20.6-10.fc14.x86_64 was supposed to be removed but is not!

Removed:
  gpm.x86_64 0:1.20.6-10.fc14                                                  

Complete!

Comment 3 Nicolas Mailhot 2010-08-19 17:16:48 UTC
rpm-libs-4.8.1-5.fc14.x86_64
rpm-build-4.8.1-5.fc14.x86_64
rpm-python-4.8.1-5.fc14.x86_64
yum-3.2.28-3.fc14.noarch

Comment 4 Panu Matilainen 2010-08-20 05:01:02 UTC
gpm-1.20.6-10.fc14 has a typo in its %preun script, since then fixed.
"rpm -e --noscripts gpm-1.20.6-10.fc14" and move on.

Comment 5 Nikola Pajkovsky 2010-08-20 08:23:27 UTC
Update to gpm-1.20.6-11.fc14. It's already in testing repository

Comment 6 Nikola Pajkovsky 2010-08-22 12:06:51 UTC

*** This bug has been marked as a duplicate of bug 624253 ***


Note You need to log in before you can comment on or make changes to this bug.