Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625514 - 'make prep' breaks on private branches
'make prep' breaks on private branches
Status: CLOSED DUPLICATE of bug 622592
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 13:22 EDT by Steve Dickson
Modified: 2013-01-10 01:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 20:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2010-08-19 13:22:20 EDT
Description of problem:
fedpkg clone kernel
fedpkg switch-branch f14
git checkout -b pnfs-all-2.6.35-2010-08-05
make prep
fedpkg -v prep --arch=noarch
Creating module object from /Build/steved/fc/git/kernel
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1062, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 577, in prep
    mymodule = pyfedpkg.PackageModule(args.path)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 841, in __init__
    self.branch = self._findbranch()
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 787, in _findbranch
    merge = self.repo.git.config('--get', 'branch.%s.merge' % localbranch)
  File "/usr/lib/python2.6/site-packages/git/cmd.py", line 127, in <lambda>
    return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/git/cmd.py", line 342, in _call_process
    return self.execute(call, **_kwargs)
  File "/usr/lib/python2.6/site-packages/git/cmd.py", line 249, in execute
    raise GitCommandError(command, status, stderr_value)
git.errors.GitCommandError: 'git config --get branch.pnfs-all-2.6.35-2010-08-05.merge' returned exit status 1: 
make: *** [prep] Error 1

I get the same error with 'fedpkg build'



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2010-08-19 20:50:20 EDT

*** This bug has been marked as a duplicate of bug 622592 ***

Note You need to log in before you can comment on or make changes to this bug.