Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 625667 - version mismatch vmlinuz vs modules.dep when "setarch i386" on x86_64
version mismatch vmlinuz vs modules.dep when "setarch i386" on x86_64
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-20 00:06 EDT by John Reiser
Modified: 2013-01-10 01:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 13:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2010-08-20 00:06:15 EDT
Description of problem: When composing an install DVD for i686 by using "setarch i386" on x86_64, then the kernel version in isolinux/vmlinuz can be different from the one in initrd.img:/lib/modules/*/modules.dep.  The resulting DVD will boot, but won't get very far because no modules can be loaded from initrd.


Version-Release number of selected component (if applicable):
pungi-2.1.2-2.fc14.noarch


How reproducible: twice today


Steps to Reproduce:
1. Run on x86_64:  setarch i386 /usr/bin/pungi \
    -c /usr/share/spin-kickstarts/fedora-install-fedora.ks \
     --destdir=$DESTDIR --name Fedora --ver $VERSION --nosource --force
2. mount -o ro,loop Fedora-14-i386-DVD.iso /mnt
3. cd /mnt/isolinux; file vmlinuz
4. gzip -dc initrd.img | cpio --list | grep modules.dep

  
Actual results:
vmlinuz: Linux kernel x86 boot executable bzImage, version 2.6.35.2-9.fc14.i686 (mockbuild, RO-rootFS, root_dev 0x902, swap_dev 0x3, Normal VGA

modules/2.6.35-0.57.rc6.git1.fc14.i686/modules.dep.bin
modules/2.6.35-0.57.rc6.git1.fc14.i686/modules.dep

Note the version discrepancy:
  2.6.35.2-9.fc14.i686   (kernel)
  2.6.35-0.57.rc6.git1.fc14.i686   (modules.dep)

Expected results: matching vmlinuz and initrd.img:.../modules.dep


Additional info: Repositories were:
repo --name=fedora-14                            --baseurl=http://download.fedora.redhat.com/pub/fedora/linux/development/$releasever/$basearch/os
repo --name=fedora-14-updates-testing            --baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/$releasever/$basearch/

All files in /var/cache/pungi/*/* (except the "packages" directory) were removed before starting, just to try to be squeaky-clean about caching.
Comment 1 Jesse Keating 2010-08-20 13:09:17 EDT
Doing a compose using setarch is not supported no expected to work.  You need to use a full 32bit chroot in order to compose a 32bit tree on x86_64.

Note You need to log in before you can comment on or make changes to this bug.