Bug 625704 - Switch to source code packages to build the RPM
Summary: Switch to source code packages to build the RPM
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla-adblockplus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andreas Thienemann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-20 08:04 UTC by Wladimir Palant
Modified: 2012-12-09 21:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-24 03:29:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wladimir Palant 2010-08-20 08:04:42 UTC
I noticed that the Mercurial repository is exported to generate Adblock Plus source code packages. This should no longer be necessary, starting with Adblock Plus 1.2 there are downloadable source code packages - e.g. https://hg.adblockplus.org/downloads/raw-file/tip/adblockplus-1.2.2-source.tgz (that's both adblockplus and buildtools repository). Address stays the same, only the version number changes.

Comment 1 Wladimir Palant 2011-05-17 12:54:53 UTC
There have been some changes since I filed this bug. The downloads are also available under https://adblockplus.org/downloads/adblockplus-1.2.2-source.tgz and this address is preferred. And starting with the next Adblock Plus version (not Adblock Plus 1.3.7 but whatever comes after it) the command to create a build is no longer "create_xpi.pl adblockplus.xpi" but "build.py build adblockplus.xpi".

Comment 2 Fedora Update System 2012-11-23 19:48:17 UTC
mozilla-adblockplus-2.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.fc17

Comment 3 Fedora Update System 2012-11-23 19:48:34 UTC
mozilla-adblockplus-2.2.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.el6

Comment 4 Fedora Update System 2012-11-23 19:48:47 UTC
mozilla-adblockplus-2.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.fc18

Comment 5 Fedora Update System 2012-11-24 03:29:49 UTC
mozilla-adblockplus-2.2.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2012-12-01 09:51:13 UTC
mozilla-adblockplus-2.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2012-12-09 21:04:41 UTC
mozilla-adblockplus-2.2.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.