Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625860 - elf-memtest x86_64 doesn't boot
elf-memtest x86_64 doesn't boot
Status: CLOSED DUPLICATE of bug 620846
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anton Arapov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-20 11:57 EDT by Edward Sheldrake
Modified: 2014-06-18 04:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 14:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.spec file patch to use '-z max-page-size=0x1000' on x86_64 links of the ELF image (356 bytes, application/octet-stream)
2011-01-07 14:48 EST, Jack Perdue
no flags Details

  None (edit)
Description Edward Sheldrake 2010-08-20 11:57:32 EDT
Description of problem:
Trying to boot elf-memtest86+-4.10 from grub fails with
"Error 13: Invalid or unsupported executable format" if I install the x86_64 rpm. Installing the i686 rpm instead works fine (the x86_64.rpm has always contained 32bit binaries anyway).

Version-Release number of selected component (if applicable):
memtest86+-4.00-3.fc13.x86_64
memtest86+-4.10-2.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install memtest86+.x86_64
2. run /usr/sbin/memtest-setup
3. Reboot and choose Memtest86+ in grub
  
Actual results:
Error 13: Invalid or unsupported executable format

Expected results:
memtest86+ runs

Additional info:
In Fedora 12 (and the Fedora 13 .i686.rpm), the memtest and elf-memtest image files are about the same size, and elf-memtest works. In Fedora 13 x86_64, elf-memtest is about 1MB larger, and doesn't work.

This is possibly due to the version of binutils in f13 - I built memtest86+-4.10-2.fc13 on Fedora 13 x86_64 but using binutils-2.19.51.0.14-37.fc12, and memtest and memtest.bin end up about the same size (but I didn't test them).
Comment 1 Edward Sheldrake 2010-08-20 14:44:25 EDT

*** This bug has been marked as a duplicate of bug 620846 ***
Comment 2 Jack Perdue 2011-01-07 14:48:13 EST
Created attachment 472284 [details]
.spec file patch to use '-z max-page-size=0x1000' on x86_64 links of the ELF image
Comment 3 Jack Perdue 2011-01-07 15:05:12 EST
[oops... wrong bug for attachment... see https://bugzilla.redhat.com/show_bug.cgi?id=620846]

Note You need to log in before you can comment on or make changes to this bug.