Bug 625894 - kwin freezes when changing related settings in systemsettings while compositing is active
kwin freezes when changing related settings in systemsettings while compositi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
AcceptedNTH
: Patch, Triaged
Depends On:
Blocks: kde-4.5 F14Blocker-kde F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-08-20 14:02 EDT by Carl G.
Modified: 2010-10-27 18:44 EDT (History)
16 users (show)

See Also:
Fixed In Version: mesa-7.9-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-15 08:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch proposed in upstream tracker (594 bytes, patch)
2010-10-03 13:30 EDT, Rex Dieter
no flags Details | Diff
mesa-7.9 patch proposed upstream (728 bytes, patch)
2010-10-03 13:31 EDT, Rex Dieter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 241402 None None None Never
FreeDesktop.org 30220 None None None Never
Launchpad 633406 None None None Never

  None (edit)
Description Carl G. 2010-08-20 14:02:31 EDT
Description of problem:

Take a look at the upstream bug report =)

Version-Release number of selected component (if applicable):

F14
mesa-dri-drivers-7.9-0.6.fc14.x86_64
mesa-libGL-7.9-0.6.fc14.x86_64
xorg-x11-drv-ati-6.13.1-1.20100705git37b348059.fc14.x86_64
xorg-x11 : 1.8.99.906
kdebase-workspace-4.5.0-2.fc14.x86_64

01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4870] (prog-if 00 [VGA controller])

How reproducible:

Always

Steps to Reproduce:
1. Turn the desktop effects on (using OpenGL)
2. Change the window decoration (for example), click on apply
  
Actual results:

The cursor still move, the audio keep playing but everything else seems to be "frozen".

Additional info:
Comment 1 Thomas Janssen 2010-09-01 15:01:46 EDT
I can reproduce that with my HD 3650 in KDE 4.5.1

mesa-dri-drivers-7.8.1-8.fc13.x86_64
mesa-libGL-7.8.1-8.fc13.x86_64
xorg-x11-drv-ati-6.13.0-1.fc13.x86_64
kdebase-workspace-4.5.1-0.1.fc13.x86_64
Comment 2 Thomas Janssen 2010-09-01 15:30:52 EDT
In a konsole running:

export LIBGL_ALWAYS_INDIRECT=1 ; kwin --replace

makes the freeze go away.
Currently the only that can be done according to upstream bug:

http://bugs.kde.org/show_bug.cgi?id=241402#c52  and following posts.

Thanks rdieter for testing it as first in IRC :)
Comment 3 Rex Dieter 2010-09-16 11:58:26 EDT
kde upstream has come to the conclusion this is a mesa bug,
https://bugs.kde.org/show_bug.cgi?id=241402#c95

Filed here,
https://bugs.freedesktop.org/show_bug.cgi?id=30220

With small patch provided.
Comment 4 Rex Dieter 2010-09-16 13:58:20 EDT
Here's a f13 scratch build that includes the aforementioned patch,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2471720

My own initial testing (for ~20 minutes, several systemsettings modifications) has been good, no badness yet.
Comment 5 Thomas Janssen 2010-09-17 02:06:38 EDT
Confirmed. The patch seems to fix it. I changed several settings and it worked as expected. No freezing.

Thanks Rex! :)
Comment 6 Rex Dieter 2010-09-17 08:16:32 EDT
Second upstream patch candidate/scratch-build,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2472903
Comment 7 Thomas Janssen 2010-09-17 14:34:41 EDT
Works as well as expected. Seems even better. Some glitches i had are gone.
Comment 8 Rex Dieter 2010-09-17 16:14:50 EDT
And patch adapted for a f14 scratch build,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2474366
Comment 9 Rex Dieter 2010-10-03 13:30:26 EDT
Created attachment 451295 [details]
patch proposed in upstream tracker

Patch against f13's mesa-7.8.x
Comment 10 Rex Dieter 2010-10-03 13:31:50 EDT
Created attachment 451296 [details]
mesa-7.9 patch proposed upstream
Comment 11 Rex Dieter 2010-10-03 13:37:56 EDT
Testing feedback for proposed patch has been excellent.  I'd move it be reviewed and considered for fedora's packaging (or in the least, poke those in the know upstream to review this prior to f14 release).

To be clear, the impact here is fairly large kde-wise, even though compositing is not enabled by default, this issue makes kwin compositing largely useless for most users of free drivers, easily prone to display freezes.
Comment 12 Rex Dieter 2010-10-04 11:28:10 EDT
woo, ajax gave blessing on irc to incoporate this.  I'll work on it.
Comment 13 Adam Williamson 2010-10-04 15:43:17 EDT
is this the thing that makes KDE really slow in a KVM? I guess not since you say it's 'not enabled by default'?

"I'd move it be reviewed and considered for fedora's packaging"

We can certainly review this as a blocker as you've nominated, but just to reinforce, an issue does not need to be a blocker for a fix to be included in F14. Right now, the bug needs no special status, you can push a fix for this in simply by submitting an update and sending it through the normal Bodhi process. Once we hit freeze, if you want to have a patch taken through a fix you still don't need to nominate the bug as a blocker if it doesn't meet the criteria; you can nominate it as nice-to-have instead. The formal NTH process is still very new and in draft stage (up till now it's all been in various people's heads), but for practical purposes, to nominate a bug as NTH, just mark it as blocking F14-accepted instead of F14blocker .
Comment 14 Rex Dieter 2010-10-04 20:57:56 EDT
Ah, ajax hinted this to me in irc, but I failed to notice until now... seems the f14 branch in git got a new snapshot recently (newer than master/), and the patched code in question is very much different now.  This will need to be retested (removing f14 blockers until reconfirmed).

applied the patch to f13 branch at least.

Re: comment 13 , no this almost certainly isn't the kvm slow thing (still trying to get a handle on that)
Comment 15 Fedora Update System 2010-10-04 21:00:06 EDT
mesa-7.8.1-9.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mesa-7.8.1-9.fc13
Comment 16 Rex Dieter 2010-10-04 21:14:53 EDT
confirmed
mesa-libGL-7.9-0.8.fc14.x86_64
still has the problem.  kwin freezes. :(
Comment 17 Rex Dieter 2010-10-05 06:39:02 EDT
Now for some good news, 

Mesa-7.9 (final) seems to have fixed the problem.  Testing with quick-n-dirty scratch build that includes
ftp://ftp.freedesktop.org/pub/mesa/7.9/MesaLib-7.9.tar.bz2
No longer suffers from this bug,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2513625

Marking NTH
Comment 18 Orion Poplawski 2010-10-05 16:11:20 EDT
FWIW - I'm able to run Rex's mesa 7.9-0.8.fc14.1 fine on my nVidia Corporation G98 [Quadro NVS 295] box with mesa-dri-drivers-experimental installed.
Comment 19 Magnus Tuominen 2010-10-06 01:33:36 EDT
Sadly I cannot say the same, kwin still freezes just the same.

nVidia Corporation G96 [GeForce 9500 GT] (rev a1) + mesa-dri-drivers-experimental
Comment 20 Rex Dieter 2010-10-06 09:59:20 EDT
According to (k)ubuntu, a newer mesa-7.9 snapshot fixes things for them too,
https://bugs.launchpad.net/kdebase/+bug/633406/comments/10
Comment 21 Rex Dieter 2010-10-08 13:43:05 EDT
caught airlied on irc, and he said a newer mesa snapshot is in the works for f14.
Comment 22 Adam Williamson 2010-10-08 14:47:08 EDT
Discussed at 2010-10-08 blocker/nth review, accepted as NTH.
Comment 23 Adam Williamson 2010-10-12 20:34:44 EDT
re-assigning to Dave. Dave, just to make sure you're aware, change deadline for F14 final is Oct 18th, we need the new mesa build before then. Thanks!

(not sure why this is in 'modified' if a fixed build isn't actually available yet?)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 James Laska 2010-10-13 12:37:08 EDT
(In reply to comment #23)
> (not sure why this is in 'modified' if a fixed build isn't actually available
> yet?)

Moving back to ASSIGNED based on previous comment
Comment 25 Fedora Update System 2010-10-13 20:08:31 EDT
mesa-7.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mesa-7.9-1.fc14
Comment 26 Dave Airlie 2010-10-13 20:11:28 EDT
okay guys please test and karma as appropriate.
Comment 27 Magnus Tuominen 2010-10-13 23:18:17 EDT
Ok, this one works for me
Comment 28 Fedora Update System 2010-10-14 09:51:26 EDT
mesa-7.9-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mesa'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mesa-7.9-1.fc14
Comment 29 Fedora Update System 2010-10-15 08:44:36 EDT
mesa-7.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Fedora Update System 2010-10-27 18:44:23 EDT
mesa-7.8.1-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.