Bug 625939 - Review Request: tintwizard - A GUI wizard which generates config files for tint2 panels
Summary: Review Request: tintwizard - A GUI wizard which generates config files for ti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 615153
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-20 20:41 UTC by Germán Racca
Modified: 2014-01-31 17:40 UTC (History)
4 users (show)

Fixed In Version: tintwizard-0.3.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-02 03:38:04 UTC
sanjay.ankur: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Germán Racca 2010-08-20 20:41:28 UTC
Spec: http://skytux.fedorapeople.org/packages/tintwizard.spec

SRPM: http://skytux.fedorapeople.org/packages/tintwizard-0.3.4-1.fc13.src.rpm

Description:
This program provides an easy way to produce configs for the popular lightweight
panel replacement tint2. By changing appearance settings through an easy to use
interface, users will be able to automatically generate a config file for tint2
and apply this to tint2 to preview their design.

Koji build from scratch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2414979

(this package depends on bug 615153)

Comment 1 Paul Howarth 2010-08-23 14:51:39 UTC
Where is the review? What has been checked?

Comment 2 Ankur Sinha (FranciscoD) 2010-08-23 15:01:29 UTC
duh.. sorry.. wrong flag.. 

Thank you for noticing Paul. 

/me heads to make more coffee

Comment 3 Ankur Sinha (FranciscoD) 2010-08-26 13:39:59 UTC
REVIEW:

+ OK
- NA
? ISSUE

+ Package meets naming and packaging guidelines
+ Spec file matches base package name.
+ Spec has consistant macro usage.
+ Meets Packaging Guidelines.
+ License
+ License field in spec matches
? License file included in package
+ Spec in American English
+ Spec is legible.
+ Sources match upstream md5sum:
[Ankur@070905042 rpmbuild]$ md5sum tintwizard-0.3.4.tar.gz SOURCES/tintwizard-0.3.4.tar.gz 
1bc8dc416623510e813a28b88e04ff2b  tintwizard-0.3.4.tar.gz
1bc8dc416623510e813a28b88e04ff2b  SOURCES/tintwizard-0.3.4.tar.gz


- Package needs ExcludeArch
+ BuildRequires correct
- Spec handles locales/find_lang
- Package is relocatable and has a reason to be.
+ Package has %defattr and permissions on files is good.
+ Package has a correct %clean section.
+ Package has correct buildroot
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+ Package is code or permissible content.
- Doc subpackage needed/used.
+ Packages %doc files don't affect runtime.

- Headers/static libs in -devel subpackage.
- Spec has needed ldconfig in post and postun
- .pc files in -devel subpackage/requires pkgconfig
- .so files in -devel subpackage.
- -devel package Requires: %{name} = %{version}-%{release}
- .la files are removed.

+ Package is a GUI app and has a .desktop file

+ Package compiles and builds on at least one arch.
+ Package has no duplicate files in %files.
+ Package doesn't own any directories other packages own.
+ Package owns all the directories it creates.
+ No rpmlint output.

Some spelling suggestions.. Ignorable. 

SHOULD Items:

+ Should build in mock.
+ Should build on all supported archs
+ Should function as described.
- Should have sane scriptlets.
- Should have subpackages require base package with fully versioned depend.
+ Should have dist tag
+ Should package latest version
- check for outstanding bugs on package. (For core merge reviews)


ISSUES:

Please include a copy of the GPLv3 in the RPM. You can add it as another SOURCE. Apart from that the package looks okay. Will be approved once you've done that :)

regards,
Ankur

Comment 4 Germán Racca 2010-08-27 20:59:45 UTC
Hello Ankur,

Thanks for the review! Please find updated files here:

SPEC: http://skytux.fedorapeople.org/packages/tintwizard.spec

SRPM: http://skytux.fedorapeople.org/packages/tintwizard-0.3.4-2.fc13.src.rpm

Regards,
Germán.

Comment 5 Ankur Sinha (FranciscoD) 2010-08-28 04:01:23 UTC
XXX APPROVED!! XXX

Please continue with the git requests etc. 

Ankur :)

Comment 6 Germán Racca 2010-08-28 19:29:34 UTC
Many thanks Ankur!! :)


New Package SCM Request
=======================
Package Name: tintwizard
Short Description: A GUI wizard which generates config files for tint2 panels
Owners: skytux
Branches: f12 f13 f14
InitialCC:

Comment 7 Kevin Fenzi 2010-08-29 19:02:20 UTC
Git done (by process-git-requests).
(do remember to assign the review bug to the reviewer)

Comment 8 Germán Racca 2010-08-30 20:41:31 UTC
Kevin: Dou you mean this bug is not assigned to the reviewer Ankur Sinha?

Comment 9 Fedora Update System 2010-08-30 21:16:40 UTC
tintwizard-0.3.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/tintwizard-0.3.4-2.fc14

Comment 10 Fedora Update System 2010-08-30 21:40:43 UTC
tintwizard-0.3.4-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/tintwizard-0.3.4-2.fc13

Comment 11 Fedora Update System 2010-08-30 21:54:02 UTC
tintwizard-0.3.4-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/tintwizard-0.3.4-2.fc12

Comment 12 Fedora Update System 2010-08-31 06:25:35 UTC
tintwizard-0.3.4-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tintwizard'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/tintwizard-0.3.4-2.fc13

Comment 13 Fedora Update System 2010-09-09 01:11:25 UTC
tintwizard-0.3.4-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-09-09 01:18:14 UTC
tintwizard-0.3.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-09-09 04:33:16 UTC
tintwizard-0.3.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 leigh scott 2014-01-14 08:38:24 UTC
Package Change Request
======================
Package Name: tintwizard
New Branches: epel7
Owners: leigh123linux

Comment 17 leigh scott 2014-01-14 08:44:21 UTC
Hi Germán,

Can I have a epel7 branch please?
I need it for my cinnamon port.


cinnamon has broken dependencies in the epel-7 tree:
On x86_64:
	cinnamon-2.0.14-7.el7.x86_64 requires zukitwo-gtk3-theme
	cinnamon-2.0.14-7.el7.x86_64 requires zukitwo-gtk2-theme
	cinnamon-2.0.14-7.el7.x86_64 requires tint2
	cinnamon-2.0.14-7.el7.x86_64 requires gnome-themes
	cinnamon-2.0.14-7.el7.x86_64 requires blueman
On ppc64:
	cinnamon-2.0.14-7.el7.ppc64 requires zukitwo-gtk3-theme
	cinnamon-2.0.14-7.el7.ppc64 requires zukitwo-gtk2-theme
	cinnamon-2.0.14-7.el7.ppc64 requires tint2
	cinnamon-2.0.14-7.el7.ppc64 requires gnome-themes
	cinnamon-2.0.14-7.el7.ppc64 requires blueman
Please resolve this as soon as possible.


Many thanks

Leigh

Comment 18 Gwyn Ciesla 2014-01-14 13:09:47 UTC
Any comments from the Fedora maintainers?

Comment 19 Germán Racca 2014-01-31 17:24:12 UTC
(In reply to leigh scott from comment #17)
> Hi Germán,
> 
> Can I have a epel7 branch please?
> I need it for my cinnamon port.
> 
> 
> cinnamon has broken dependencies in the epel-7 tree:
> On x86_64:
> 	cinnamon-2.0.14-7.el7.x86_64 requires zukitwo-gtk3-theme
> 	cinnamon-2.0.14-7.el7.x86_64 requires zukitwo-gtk2-theme
> 	cinnamon-2.0.14-7.el7.x86_64 requires tint2
> 	cinnamon-2.0.14-7.el7.x86_64 requires gnome-themes
> 	cinnamon-2.0.14-7.el7.x86_64 requires blueman
> On ppc64:
> 	cinnamon-2.0.14-7.el7.ppc64 requires zukitwo-gtk3-theme
> 	cinnamon-2.0.14-7.el7.ppc64 requires zukitwo-gtk2-theme
> 	cinnamon-2.0.14-7.el7.ppc64 requires tint2
> 	cinnamon-2.0.14-7.el7.ppc64 requires gnome-themes
> 	cinnamon-2.0.14-7.el7.ppc64 requires blueman
> Please resolve this as soon as possible.
> 
> 
> Many thanks
> 
> Leigh

Hi Leigh,

Sorry for reading this too late.

Of course you can have the epel branch, but just tell me what I have to do please :)

Germán.

Comment 20 Gwyn Ciesla 2014-01-31 17:40:11 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.