Bug 626047 - SELinux is preventing /usr/sbin/ulogd "read" access on hosts.
Summary: SELinux is preventing /usr/sbin/ulogd "read" access on hosts.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0938e221897...
: 626074 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-21 16:13 UTC by Joseph D. Wagner
Modified: 2010-08-31 06:39 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.7.19-51.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-31 06:39:32 UTC


Attachments (Terms of Use)

Description Joseph D. Wagner 2010-08-21 16:13:47 UTC
Summary:

SELinux is preventing /usr/sbin/ulogd "read" access on hosts.

Detailed Description:

SELinux denied access requested by ulogd. It is not expected that this access is
required by ulogd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ulogd_t:s0
Target Context                system_u:object_r:net_conf_t:s0
Target Objects                hosts [ file ]
Source                        ulogd
Source Path                   /usr/sbin/ulogd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ulogd-1.24-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-49.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.6-147.2.4.fc13.x86_64 #1 SMP Fri Jul 23
                              17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Sat 21 Aug 2010 09:07:50 AM PDT
Last Seen                     Sat 21 Aug 2010 09:07:50 AM PDT
Local ID                      845a8340-b63c-4dce-86cd-4c10e1a4b761
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282406870.542:13): avc:  denied  { read } for  pid=1443 comm="ulogd" name="hosts" dev=sdb5 ino=262182 scontext=system_u:system_r:ulogd_t:s0 tcontext=system_u:object_r:net_conf_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1282406870.542:13): arch=c000003e syscall=2 success=no exit=-13 a0=7f3fa55b7286 a1=80000 a2=1b6 a3=0 items=0 ppid=1442 pid=1443 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ulogd" exe="/usr/sbin/ulogd" subj=system_u:system_r:ulogd_t:s0 key=(null)

Notes:

I relabeled my drive on reboot just to try to be safe.  Unfortunately, that didn't help.
Hash String generated from  catchall,ulogd,ulogd_t,net_conf_t,file,read
audit2allow suggests:

#============= ulogd_t ==============
allow ulogd_t net_conf_t:file read;

Comment 1 Joseph D. Wagner 2010-08-21 16:19:44 UTC
Related to https://bugzilla.redhat.com/show_bug.cgi?id=624378

Comment 2 Miroslav Grepl 2010-08-22 22:08:38 UTC
*** Bug 626074 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-08-24 12:42:39 UTC
Fixed in selinux-policy-3.7.19-50.fc13

Comment 4 Fedora Update System 2010-08-25 15:36:25 UTC
selinux-policy-3.7.19-51.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 5 Fedora Update System 2010-08-26 00:59:10 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 6 Joseph D. Wagner 2010-08-29 01:03:39 UTC
Tests ok.

Comment 7 Fedora Update System 2010-08-31 06:38:20 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.