Bug 626084 - SELinux is preventing /usr/sbin/ulogd "getattr" access .
SELinux is preventing /usr/sbin/ulogd "getattr" access .
Status: CLOSED DUPLICATE of bug 626078
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:52bbf9a86b3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-21 15:57 EDT by Joseph D. Wagner
Modified: 2010-08-22 17:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 17:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph D. Wagner 2010-08-21 15:57:02 EDT
Summary:

SELinux is preventing /usr/sbin/ulogd "getattr" access .

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ulogd. It is not expected that this access is
required by ulogd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ulogd_t:s0
Target Context                system_u:system_r:ulogd_t:s0
Target Objects                None [ tcp_socket ]
Source                        ulogd
Source Path                   /usr/sbin/ulogd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ulogd-1.24-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-49.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.6-147.2.4.fc13.x86_64 #1 SMP Fri Jul 23
                              17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Sat 21 Aug 2010 09:21:02 AM PDT
Last Seen                     Sat 21 Aug 2010 12:49:41 PM PDT
Local ID                      efeb1219-da9f-4993-961a-12c4d1e5bb55
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282420181.744:22): avc:  denied  { getattr } for  pid=1407 comm="ulogd" laddr=::1 lport=55332 faddr=::1 fport=5432 scontext=system_u:system_r:ulogd_t:s0 tcontext=system_u:system_r:ulogd_t:s0 tclass=tcp_socket

node=(removed) type=SYSCALL msg=audit(1282420181.744:22): arch=c000003e syscall=51 success=yes exit=0 a0=5 a1=7279f0 a2=727a70 a3=7fff2b0d181c items=0 ppid=1406 pid=1407 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ulogd" exe="/usr/sbin/ulogd" subj=system_u:system_r:ulogd_t:s0 key=(null)



Hash String generated from  catchall,ulogd,ulogd_t,ulogd_t,tcp_socket,getattr
audit2allow suggests:

#============= ulogd_t ==============
allow ulogd_t self:tcp_socket getattr;
Comment 1 Miroslav Grepl 2010-08-22 17:36:26 EDT

*** This bug has been marked as a duplicate of bug 626078 ***

Note You need to log in before you can comment on or make changes to this bug.