Bug 626107 - ifup script for bridge device does not properly obtain the default route
ifup script for bridge device does not properly obtain the default route
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-21 20:39 EDT by Russ
Modified: 2010-09-13 04:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 04:39:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russ 2010-08-21 20:39:34 EDT
Description of problem:
When using libvirt with bridged networking you must manually configure a bridge device as per instructions on the libvirt wiki:
<a href>http://wiki.libvirt.org/page/Networking</a>

In Fedora 12 the bridge device worked fine and properly obtained all settings via DHCP. In Fedora 13, however, the bridge device does not obtain the default route. The default route must be manually added afterwards by using the command:
route add default gw <gateway address>

The component is listed as initscripts since that is the package that contains the ifup script. I'm not certain if the problem is in the networking scripts or somewhere else like the dhclient. All I know is the bridge worked fine in F12 and now it does not in F13. Please refer the issue to the proper maintainer if it is not an initscripts issue.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. add bridge device (it is not necessary to have libvirt installed)
2. /sbin/service network restart
3. is there a default route?
  
Actual results:
no default route is configured

Expected results:
a default route is configured

Additional info:
Comment 1 Bill Nottingham 2010-08-23 11:56:14 EDT
Is NetworkManager active?
Comment 2 Russ 2010-09-05 21:39:43 EDT
(In reply to comment #1)
> Is NetworkManager active?

No.

Please, please, don't ask us to activate it. . . ;)
Comment 3 Bill Nottingham 2010-09-07 13:04:03 EDT
Just making sure.

dhclient-script sets the default route. Assigning there.
Comment 4 Russ 2010-09-08 15:20:29 EDT
Not a bug after all. Just a change in behaviour in updated packages, and a lack of good documentation in http://wiki.libvirt.org/page/Networking.

Problem turned out to be the following:

In "NORMAL" network configurations a VERY sparse /etc/sysconfig/network is all that is needed:

~]$ cat /etc/sysconfig/network
NETWORKING=yes

But if you are using a bridge device such as when using libvirt you MUST specify the default gateway device:

~]$ cat /etc/sysconfig/network
NETWORKING=yes
GATEWAYDEV=br0

If you do not specify the default gateway device in either the main network configuration file (/etc/sysconfig/network), or in the configuration file for actual gateway device (/etc/sysconfig/network-scripts/ifcfg-br0) the default route will never be configured.

So if GATEWAYDEV=br0 is only present in ifcfg-ethX the default route will never get configured.

Better documentation of this behaviour is needed, as after the update from F12 to F13 until now we had to use a script to configure the default route.
Comment 5 Jiri Popelka 2010-09-13 04:39:31 EDT
Thank you for the explanation. Closing as notabug then.

Note You need to log in before you can comment on or make changes to this bug.