Bug 62613 - Driver disk still mounted when I go to create a boot disk
Driver disk still mounted when I go to create a boot disk
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-02 22:48 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 15:38:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2002-04-02 22:48:30 EST
Description of Problem:
I was caught out be an odd gotcha.  Probably my fault, but it was unexpected
behaviour.
When I was getting near the end of the install, I put a blank diskette in the
drive ready for boot disk creation. I then hit the button to say yes, create a
disk, and then I saw some error messages relating to the driver disk (and an
error on one of the other VTs saying that the floppy could not be unmounted due
to "busy inodes on changed media").  Boot disk creation then failed.
I'm slightly hazy on the sequence of events here; I'm fairly sure that the
errors appeared after I said "yes, there's a blank disk there you can put the
boot image on" but it may have been just before.  Either way, I wasn't expecting
the previous disk (drvnet) to still be in use at that point since once it's
insmod'd there's no longer any need for the module to be available.
Could the driver disk be unmounted earlier on in the process? I had assumed this
was done earlier on, after the contents were read in.
Comment 1 Michael Fulbright 2002-04-04 12:41:47 EST
Jeremy can you verify this please?
Comment 2 Jeremy Katz 2002-04-04 14:05:27 EST
I haven't seen this in as I've looked at driver disks over the past day or two.
 I have a couple other things to verify with driver disks, though, so will
double-check that everything is getting unmounted as I do so.
Comment 3 Bill Crawford 2002-04-04 15:09:31 EST
It's more a question of *when* it gets unmounted, I was caught out as anaconda
was trying to unmount the driver disk as I was inserting the blank disk ready
for boot disk creation.  It is being unmounted, but I think that needs to happen
a bit earlier in the process (ideally before package installation begins, so I
have plenty of time to swap disks).  I'll also concede that technically it's my
fault as I was a little eager about swapping the disks.
Comment 4 Jeremy Katz 2002-04-04 15:30:31 EST
I just did an install with a driver disk to test something else.  The driver
disk is getting unmounted in the loader immediately after reading the drivers
off for me.  Is this reproducible for you?
Comment 5 Bill Crawford 2002-04-04 15:37:57 EST
It might depend on whether it's done by booting with "linux dd" or by pressing
F2 to access the driver disk before setting up the network.  I'm going to have
to find another machine to test on as the one I installed is tucked away in the
corner of the room acting as my caching nameserver and squid cache :o)

I'd restarted the install several times (to mess with the partition table) so I
can't remember which method I used the last time.  I only discovered the "press
F2 to access a driver disk" option by accident after I'd forgotten to add the dd
option when booting.
Comment 6 Jeremy Katz 2002-04-08 19:41:43 EDT
I've done both without problems.  If you can reproduce this and give a clear set
of steps to reproduce it, please reopen with that information as well as any
information from /tmp/syslog about errors unmounting. Otherwise, I'm going to
mark it up as a fluke or something.
Comment 7 Bill Crawford 2002-04-08 21:09:54 EDT
I don't have a spare which needs the driver disk, unfortunately.  The machine I
was testing on is now in a cupboard acting as my squid cache.  I don't consider
it a critical problem, anyway.  It only happens if you jump the gun with
changing floppies.  I suspect most first-timers won't do that, and experienced
folk will understand the error messages :o)

Try taking the driver disk out just before package installation finishes?

/tmp/install.log.syslog was empty after reboot, which might also be considered a
bug.  install.log just lists the packages installed (all 157), no errors.

Note You need to log in before you can comment on or make changes to this bug.