Bug 626167 - SELinux is preventing /usr/sbin/ssmtp "getattr" access on /etc/aliases.
Summary: SELinux is preventing /usr/sbin/ssmtp "getattr" access on /etc/aliases.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:7badf128d85...
: 625969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-22 13:07 UTC by Tobias Mueller
Modified: 2010-08-31 06:39 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-51.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-31 06:39:00 UTC


Attachments (Terms of Use)

Description Tobias Mueller 2010-08-22 13:07:44 UTC
Summary:

SELinux is preventing /usr/sbin/ssmtp "getattr" access on /etc/aliases.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by sendmail. It is not expected that this access
is required by sendmail and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_aliases_t:s0
Target Objects                /etc/aliases [ file ]
Source                        sendmail
Source Path                   /usr/sbin/ssmtp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ssmtp-2.61-15.fc13
Target RPM Packages           setup-2.8.20-1.fc13
Policy RPM                    selinux-policy-3.7.19-47.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.6-147.2.4.fc13.x86_64 #1 SMP
                              Fri Jul 23 17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   6
First Seen                    Sa 14 Aug 2010 03:36:09 CEST
Last Seen                     So 22 Aug 2010 03:07:09 CEST
Local ID                      fece0329-00b2-4531-a498-957bc3507db7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282439229.44:6152): avc:  denied  { getattr } for  pid=27082 comm="sendmail" path="/etc/aliases" dev=dm-1 ino=7065720 scontext=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_aliases_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1282439229.44:6152): arch=c000003e syscall=5 success=yes exit=0 a0=4 a1=7fff8d76a7c0 a2=7fff8d76a7c0 a3=0 items=0 ppid=26931 pid=27082 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1002 comm="sendmail" exe="/usr/sbin/ssmtp" subj=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,sendmail,logwatch_mail_t,etc_aliases_t,file,getattr
audit2allow suggests:

#============= logwatch_mail_t ==============
allow logwatch_mail_t etc_aliases_t:file getattr;

Comment 1 Daniel Walsh 2010-08-23 14:08:44 UTC
Miroslav add 

read_files_pattern(user_mail_domain, etc_aliases_t, etc_aliases_t)


To mta.te

Comment 2 Miroslav Grepl 2010-08-24 11:51:16 UTC
Fixed in selinux-policy-3.7.19-50.fc13

Comment 3 Miroslav Grepl 2010-08-24 11:51:34 UTC
*** Bug 625969 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-08-25 15:35:51 UTC
selinux-policy-3.7.19-51.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 5 Fedora Update System 2010-08-26 00:58:38 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-51.fc13

Comment 6 Fedora Update System 2010-08-31 06:37:48 UTC
selinux-policy-3.7.19-51.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.