Bug 62619 - mc destroyed zip archive by merely browsing it
mc destroyed zip archive by merely browsing it
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mc (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-03 00:38 EST by vvs
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 12:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2002-04-03 00:38:09 EST
Description of Problem:

If you try to browse zip archive contained inside another zip, the latter will
be modified by merely browsing it, thus destroying the original. Ouch!

Version-Release number of selected component (if applicable):

mc-4.5.55-2

How Reproducible:

Always

Steps to Reproduce:
1. create a zip archive
2. add this zip to another zip archive
3. run mc and try to browse this internal zip inside
4. now leave mc

Actual Results:

The zip archive which contained that other zip will be modified, destroying the
original contents.

Expected Results:

It should not modify archive just because you are browsing it

Additional Information:
Comment 1 Havoc Pennington 2002-04-10 11:31:01 EDT
that's certainly unfortunate...
Comment 2 Jakub Jelinek 2002-04-10 12:01:41 EDT
Guess mc issues copyin even if the file has not changed (though admit I haven't seen the extfs code for years).
BTW: It looks like all the scripts in /usr/lib/mc/extfs/
should be using mktemp and mktemp -d where appropriate.
Comment 3 Havoc Pennington 2002-04-11 14:44:51 EDT
4.5.55-4 fixes this

Note You need to log in before you can comment on or make changes to this bug.