Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626220 - AttributeError: VolumeGroupEditor instance has no attribute 'volnameEntry'
AttributeError: VolumeGroupEditor instance has no attribute 'volnameEntry'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:683b119161ad933b7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-22 15:50 EDT by Geert Jansen
Modified: 2013-03-13 02:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 15:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (354.99 KB, text/plain)
2010-08-22 15:50 EDT, Geert Jansen
no flags Details
Traceback as requested (365.97 KB, text/plain)
2010-08-23 03:39 EDT, Geert Jansen
no flags Details

  None (edit)
Description Geert Jansen 2010-08-22 15:50:21 EDT
The following was filed automatically by anaconda:
anaconda 14.15 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 1018, in convertToActions
    volname = self.volnameEntry.get_text().strip()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1776, in editLVMLogicalVolume
    actions = vgeditor.convertToActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1638, in editCB
    self.editLVMLogicalVolume(lv = device)
AttributeError: VolumeGroupEditor instance has no attribute 'volnameEntry'
Comment 1 Geert Jansen 2010-08-22 15:50:28 EDT
Created an attachment (id=440253)
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-08-22 19:15:48 EDT
Looks like exception reporting has somehow broken - something must be going wrong with either report or python-bugzilla.  Can you please attach /tmp/anaconda-tb-* to this report?
Comment 3 Geert Jansen 2010-08-23 03:39:05 EDT
Created attachment 440310 [details]
Traceback as requested
Comment 4 Chris Lumens 2010-08-23 10:25:13 EDT
Looking at the code, I don't see how that situation is possible.  Did you do something where you went back and forth between UI elements, possibly causing a dialog to come and go during partitioning setup?
Comment 5 Geert Jansen 2010-08-23 11:16:35 EDT
Not sure what you would be back and forth. My usage of the GUI was pretty basic. The system is already partitioned and a few partitions needed to be preserved. I used "custom layout" when selecting how to partition. Then i click on an LV, configure the mount point, and hit OK. At that point i get the exception.

I got the same problem in F13 too.
Comment 6 Chris Lumens 2010-08-24 15:49:19 EDT
We are completely unable to reproduce this error in testing, and I've never heard any other reports along these lines.  Something weird is going on, but I don't know what.
Comment 7 Geert Jansen 2010-08-25 03:17:22 EDT
Obviously there's a bug though. I was able to get it to bomb out consistently. I'll try again on my new install, see if it bombs out there as well.

Note You need to log in before you can comment on or make changes to this bug.