Bug 626243 - [abrt] "After the Deadline" OpenOffice.org java extension: gnu_java_awt_peer_gtk_GtkToolkit.c:102 killed by signal 6 (SIGABRT)
Summary: [abrt] "After the Deadline" OpenOffice.org java extension: gnu_java_awt_peer_...
Status: CLOSED DUPLICATE of bug 668777
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Andrew Haley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f54d471ba9c9f69f47758491453...
Keywords:
: 630383 662372 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-22 23:39 UTC by dweb98
Modified: 2011-01-11 16:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-11 16:15:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (182.54 KB, text/plain)
2010-08-22 23:39 UTC, dweb98
no flags Details
Screenshot-Fedora-13-OpenOffice-Writer-Extension Manager.png (127.73 KB, image/png)
2010-09-01 09:49 UTC, dweb98
no flags Details

Description dweb98 2010-08-22 23:39:26 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.33.6-147.2.4.fc13.i686
package: openoffice.org-writer-1:3.2.0-12.29.fc13
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
time: 1282512897
uid: 500

How to reproduce
-----
1.Spell check a .doc document
2.moved spell check window
3.crash

Comment 1 dweb98 2010-08-22 23:39:28 UTC
Created an attachment (id=440270)
File: backtrace

Comment 2 David Tardon 2010-08-23 07:07:06 UTC
This looks like a general memory problem, nothing specific to openoffice.org. I bet you cannot reproduce it, right?

Comment 3 Caolan McNamara 2010-08-23 08:04:21 UTC
Looks like a g_idle callback registered by some part of the gtk stuff in the libgcj Java stack.

I suspect there's an additional java OOo extension installed as I don't think we have anything that uses a normal java AWT in the default OOo java stack

Comment 4 David Tardon 2010-08-23 08:52:33 UTC
Yeah, and I suspect that extension is Language Tool (http://extensions.services.openoffice.org/project/languagetool). Definitely crashes just by running here ;)

Comment 5 dweb98 2010-09-01 09:30:19 UTC
(In reply to comment #2)
> This looks like a general memory problem, nothing specific to openoffice.org. I
> bet you cannot reproduce it, right?

You're right, it didn't crash this time when I tried to make it crash. After reading the other comments. I only have extendedPDF Add-on installed. Ok, well there's a kicker for ya!:O I opened Writer to see what add-ons I had and it crashed! I had opened and closed it about 3 times in under a minute. I wonder... 

That reminds me... I want to install Alternative Searching Add-on to this System. I have it on my other one and like it. Hope it doesn't cause problems. It hasn't on my other Fedora 13 System though. 

Don

Comment 6 dweb98 2010-09-01 09:48:29 UTC
Well, I spoke too soon about having only one add-on. When I was installing Alternative Search. I saw several others in the Extension manager that don't show up in the Tools menu. I'm uploading a screen shot to show what I have now. 

Don

Comment 7 dweb98 2010-09-01 09:49:31 UTC
Created attachment 442368 [details]
Screenshot-Fedora-13-OpenOffice-Writer-Extension Manager.png

Well, I spoke too soon about having only one add-on. When I was installing Alternative Search. I saw several others in the Extension manager that don't show up in the Tools menu. I'm uploading a screen shot to show what I have now. 

Don

Comment 8 David Tardon 2010-09-01 11:16:38 UTC
I suspect it's the "After the Deadline" extension that's causing this.

Comment 9 dweb98 2010-09-01 12:07:52 UTC
(In reply to comment #8)
> I suspect it's the "After the Deadline" extension that's causing this.

Ok, thanks. Then I will un-install After the Deadline on both machines. I don't need anything crashing when I'm trying to work... 

Don

Comment 10 Caolan McNamara 2010-09-05 15:31:13 UTC
*** Bug 630383 has been marked as a duplicate of this bug. ***

Comment 11 Caolan McNamara 2011-01-06 16:20:31 UTC
*** Bug 662372 has been marked as a duplicate of this bug. ***

Comment 12 Caolan McNamara 2011-01-06 16:22:40 UTC
Seems indeed to be after the deadline that triggers it, though AKAICS atd doesn't make any direct java awt calls. Played around with it and can't reproduce this myself however.

Comment 13 Caolan McNamara 2011-01-11 16:15:04 UTC

*** This bug has been marked as a duplicate of bug 668777 ***


Note You need to log in before you can comment on or make changes to this bug.