Bug 626246 - [abrt] bluefish-2.0.1-1.fc13: IA__g_str_hash: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
[abrt] bluefish-2.0.1-1.fc13: IA__g_str_hash: Process /usr/bin/bluefish was k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluefish (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
abrt_hash:7b9b395c91221e1c4cd0055d653...
:
: 630448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-22 19:44 EDT by clifford snow
Modified: 2010-09-08 02:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: bluefish-2.0.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-08 02:45:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.59 KB, text/plain)
2010-08-22 19:44 EDT, clifford snow
no flags Details
Patch (1.19 KB, patch)
2010-08-26 00:11 EDT, Jim Hayward
no flags Details | Diff

  None (edit)
Description clifford snow 2010-08-22 19:44:55 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: bluefish
component: bluefish
crash_function: IA__g_str_hash
executable: /usr/bin/bluefish
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: bluefish-2.0.1-1.fc13
rating: 4
reason: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282520211
uid: 501

comment
-----
This was the first time opening a file since installing bluefish.  Go figure.  Opening the file 
by just selecting the file worked.  

How to reproduce
-----
1. Opened Bluefish
2. Clicked on File, Open 
3. Selected file directory ~/Downloads
4. In the Open file dialog window, attempted to filter just web files
Comment 1 clifford snow 2010-08-22 19:44:57 EDT
Created an attachment (id=440272)
File: backtrace
Comment 2 Jim Hayward 2010-08-26 00:11:44 EDT
Created attachment 441107 [details]
Patch

I wonder how that bug was missed for so long. I guess no one uses the file filters.

Anyway fixed upstream. Will be part of the 2.0.2 release. Thanks for the bug report.

Paul, patch attached to fix the Fedora package until 2.0.2 is released.
Comment 3 Fedora Update System 2010-08-26 06:39:54 EDT
bluefish-2.0.1-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/bluefish-2.0.1-2.fc14
Comment 4 Fedora Update System 2010-08-26 06:39:59 EDT
bluefish-2.0.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bluefish-2.0.1-2.fc13
Comment 5 Paul Howarth 2010-09-05 14:07:36 EDT
*** Bug 630448 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-09-07 22:23:43 EDT
bluefish-2.0.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-09-08 00:36:23 EDT
bluefish-2.0.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.