Bug 626254 - Entities don't get used in spec file %description
Summary: Entities don't get used in spec file %description
Status: CLOSED ERRATA
Alias: None
Product: Publican
Classification: Community
Component: publican (Show other bugs)
(Show other bugs)
Version: 1.6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-23 00:11 UTC by Ruediger Landmann
Modified: 2010-11-24 04:19 UTC (History)
4 users (show)

Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 20:43:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ruediger Landmann 2010-08-23 00:11:46 UTC
Description of problem:
If the abstract of a book contains an entity, this entity does not get replaced when generating the %description section of the spec file.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. Place an entity in the <abstract> of a book
2. Run publican package
  
Actual results:
Entity is omitted in the %description 

Expected results:
Entity is replaced in the %description

Additional info:
Entities in the <subtitle> get replaced properly in the spec file %summary section, so this problem is specific to the %description.

Comment 1 Jeff Fearn 2010-09-29 05:39:18 UTC
This is due to the abstract being processed differently because it needs to be hard wrapped to meet spec file guidelines. It's going take a while to get around to fixing this one.

Comment 2 Jeff Fearn 2010-10-04 01:03:47 UTC
Fixed in build: 2.1-0%{?dist}.t138

Comment 3 Fedora Update System 2010-10-06 05:50:02 UTC
publican-2.2-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc13

Comment 4 Fedora Update System 2010-10-06 05:51:17 UTC
publican-2.2-0.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc12

Comment 5 Fedora Update System 2010-10-06 05:51:17 UTC
publican-2.2-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc14

Comment 6 Fedora Update System 2010-10-08 20:41:26 UTC
publican-2.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.