Bug 626314 - FutureFeature: add presets to wxGTK-devel package
Summary: FutureFeature: add presets to wxGTK-devel package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK
Version: 13
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-23 07:32 UTC by og
Modified: 2010-12-08 21:43 UTC (History)
1 user (show)

Fixed In Version: wxGTK-2.8.11-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-08 21:34:06 UTC
Type: ---


Attachments (Terms of Use)

Description og 2010-08-23 07:32:12 UTC
Description of problem:
presets for bakefile builds are not part of the devel package.

Version-Release number of selected component (if applicable):
wxGTK-devel-2.8.11-1.fc13

How reproducible:
Install devel package

Expected results:
Since bakefile is a convenient way to develop cross platform build for wxWidgets based software it would be nice if the presets (./build/bakefiles/wxpresets/presets in the source archive) would be part of the devel package. At present the source archive has to be downloaded separately to get hold of the presets.

Additional information:
You will probably not need the presets if you just download a source archive of a software using wxWidgets and want to compile it. However you will need those files if you actually try to develop a wxWidget cross platform application yourself (see http://svn.wxwidgets.org/viewvc/wx/wxWidgets/trunk/build/bakefiles/wxpresets/bakefile_quickstart.txt?view=co).

Comment 1 Dan Horák 2010-08-24 07:24:12 UTC
The presets were removed because bakefile wasn't packaged in Fedora, but now it is and it makes sense to add them back.

Comment 2 Fedora Update System 2010-11-29 17:40:50 UTC
wxGTK-2.8.11-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-3.fc14

Comment 3 Fedora Update System 2010-11-29 17:41:01 UTC
wxGTK-2.8.11-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/wxGTK-2.8.11-2.fc13

Comment 4 Fedora Update System 2010-11-30 22:23:00 UTC
wxGTK-2.8.11-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxGTK'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/wxGTK-2.8.11-3.fc14

Comment 5 Fedora Update System 2010-12-08 21:33:56 UTC
wxGTK-2.8.11-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-12-08 21:43:17 UTC
wxGTK-2.8.11-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.