Bug 62640 - Remove sendmail from Base component
Remove sendmail from Base component
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-03 12:35 EST by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 12:36:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2002-04-03 12:35:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.1 (CVS >= 20020327); Linux)

Description of problem:
Now that we're shipping postfix, sendmail shouldn't be in the base component anymore.
Having it there makes it impossible to install a postfix system without post-install hackery (calling alternatives or rpm -e sendmail).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a box for use with postfix
2. Notice sendmail is installed because it's in Base
3. Notice sendmail is treated as the preferred MTA even though postfix was selected
 

Additional info:
Comment 1 Tim Powers 2002-04-03 12:53:37 EST
You are incorrect.  Install postfix, then use redhat-switchmail to select it as
your MTA.

Not only that, but we must have an MTA in base because there are packages in
base which need an MTA. It's too late to change the inslaller to add an MTA
selection screen, so this is what we are left with.

Tim

Note You need to log in before you can comment on or make changes to this bug.