Bug 626410 - evince fails to remember settings (window size, fit option, etc.)
evince fails to remember settings (window size, fit option, etc.)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 09:33 EDT by Danny Yee
Modified: 2012-11-30 22:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 09:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Yee 2010-08-23 09:33:38 EDT
Evince fails to remember settings between invocations.  (Forcing users to resize windows and/or change to "best fit" on every invocation.)


No problem in Fedora 12, but not working in Fedora 13.


Reproducible by running evince, changing the window size, quitting, and then restarting.  The initial window geometry and fit option isn't preserved.

This appears to have been fixed upstream. See https://bugzilla.gnome.org/show_bug.cgi?id=606090
Comment 1 Marek Kašík 2010-09-13 07:15:58 EDT
Hi Danny,

this should be fixed now. The commit was included in evince 2.30.1 and there is evince 2.30.3 in Fedora 13 now.
Could you confirm that?

Regards

Marek
Comment 2 Danny Yee 2010-09-13 07:39:10 EDT
Still not working for me (evince 2.30.3 in Fedora 13).

If I open a document, resize the window and change "Fit Page Width" to "Best Fit", and then close the document, none of those changes are preserved when I reopen that document (or any other document).

But I'm not running a desktop, just a bare window manager... Is there something I need to change in the GNOME config to get evince to save settings?
Comment 3 Danny Yee 2010-09-13 07:47:36 EDT
There are what look like config files, including a zero-length "last_settings" file in ~/.gnome2/evince, but from reading comments on this bug in other systems it sounds like this is the "old" solution leftover from Fedora 12 - and there's also a zero-length "migrated-to-gvfs" file in this directory.

I have gvfsd and gvfs-fuse-daemon running (though I don't know what started them), but there's nothing in ~/.gvfs.
Comment 4 Marek Kašík 2010-09-13 11:15:41 EDT
Which window manager do you use?
Could you try it with Gnome?
Is there a warning message when you run evince from console?

Marek
Comment 5 Danny Yee 2010-09-13 11:46:24 EDT
I get the following warnings when I run evince from a console (I'm using the ultra-minimalist 9wm, so I have no other way of starting evince).

** (evince:5953): WARNING **: Failed to create dbus proxy for org.gnome.SettingsDaemon: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

** (evince:5953): WARNING **: Setting attribute metadata::evince::sidebar_visibility not supported

I'm running a dbus-daemon - one process running as user dbus and another running with my id, plus a "dbus-launch" process running with my id.

Evince works on an entirely different computer running Fedora 13 with GNOME.  If I can work out how to run GNOME on this computer I'll give it a try - I might also try removing ~/.gnome2 and ~/.config/evince and then logging in again.
Comment 6 Marek Kašík 2010-09-14 06:14:42 EDT
I can reproduce this now. So, you don't need to try it with Gnome.
The first warning vanishes if you run /usr/libexec/gnome-settings-daemon as user (and "dbus-daemon --system" as root if needed). But it doesn't solve the problem on my virtual machine.

Marek
Comment 7 Marek Kašík 2010-09-14 09:31:14 EDT
I see the problem now. You need to launch dbus in this way: "export `dbus-launch`" to properly export environmental variables DBUS_SESSION_BUS_ADDRESS and DBUS_SESSION_BUS_PID.
Could you confirm that it works for you?

Marek

Btw, those meta information are stored as metadata of ~/.gnome2/evince/last_settings, so it can have zero size and still contains meta informations (see "gvfs-info ~/.gnome2/evince/last_settings" (with properly exported variables))
Comment 8 Danny Yee 2010-09-14 09:49:50 EDT
Thanks for the fix Marek!  That works fine, and I'm guessing adding the export `dbus-launch` to my .xinitrc will keep it working.  Thanks for the tip on gvfs-info, too.
Comment 9 Autran 2012-11-30 22:37:55 EST
I am seeing this bug in FC 17


Linux YvesDesktop 3.6.7-4.fc17.i686 #1 SMP Tue Nov 20 20:13:04 UTC 2012 i686 i686 i386 GNU/Linux.
Window man is Xfce.
evince 3.4.

Note You need to log in before you can comment on or make changes to this bug.