Bug 626423 - HWCert: RedHat v7-1.2-16 info test fails on RHEL6.0 beta2 (snap10)
Summary: HWCert: RedHat v7-1.2-16 info test fails on RHEL6.0 beta2 (snap10)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 1.2
Hardware: ppc64
OS: All
low
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-23 14:20 UTC by IBM Bug Proxy
Modified: 2010-11-19 20:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 20:31:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info test output (6.59 KB, text/plain)
2010-08-23 14:21 UTC, IBM Bug Proxy
no flags Details
SOS report (627.52 KB, application/octet-stream)
2010-08-23 14:21 UTC, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 66639 None None None Never

Description IBM Bug Proxy 2010-08-23 14:20:57 UTC
---Problem Description---
HWCert: RedHat v7-1.2-16 info test fails on RHEL6.0 snap 10

---uname output---
Linux lindap7-lp1.austin.ibm.com 2.6.32-59.el6.ppc64 #1 SMP Wed Aug 4 12:52:59
EDT 2010 ppc64 ppc64 ppc64 GNU/Linux

Machine Type =  IBM Power 750,8233-E8B 

---Steps to Reproduce---
 1. v7 run info --test=info

Comment 1 IBM Bug Proxy 2010-08-23 14:21:04 UTC
Created attachment 440397 [details]
info test output

Comment 2 IBM Bug Proxy 2010-08-23 14:21:11 UTC
Created attachment 440398 [details]
SOS report

Comment 3 Rob Landry 2010-08-24 21:05:46 UTC
The info test failed because the tainted value is "268435456" on this box which isn't an accepted value by the info test; generally speaking it should be 0.

Comment 6 IBM Bug Proxy 2010-09-07 19:22:01 UTC
------- Comment From hienn@us.ibm.com 2010-09-07 15:10 EDT-------
I have trouble bring the machine (p7 8233-E8B) up (due to install problem with rhel6 snap12 - bug#66843) to re-produce the problem. .I will use a p6 system to reproduce the problem. Will post the results soon.

I have no ideas why the tainted value is "268435456".  Is it possible if I just manually change the value of /proc/sys/kernel/tainted to be 0 ?

Comment 7 IBM Bug Proxy 2010-09-07 21:31:44 UTC
------- Comment From lnx1138@linux.vnet.ibm.com 2010-09-07 17:27 EDT-------
The value doesn't look familiar. I usually see 1 or 16 for values when not zero. While you can try the echo, the value of zero will be bitwise ORed with whatever value is there and so shouldn't change anything or clear it. Here is what Documentation/sysctl/kernel.txt describes about it. Maybe the Red Hat kernel adds additional values beyond those described or someone echoed that value somewhere unintentionally?

Non-zero if the kernel has been tainted.  Numeric values, which
can be ORed together:

1 - A module with a non-GPL license has been loaded, this
includes modules with no license.
Set by modutils >= 2.4.9 and module-init-tools.
2 - A module was force loaded by insmod -f.
Set by modutils >= 2.4.9 and module-init-tools.
4 - Unsafe SMP processors: SMP with CPUs not designed for SMP.
8 - A module was forcibly unloaded from the system by rmmod -f.
16 - A hardware machine check error occurred on the system.
32 - A bad page was discovered on the system.
64 - The user has asked that the system be marked "tainted".  This
could be because they are running software that directly modifies
the hardware, or for other reasons.
128 - The system has died.
256 - The ACPI DSDT has been overridden with one supplied by the user
instead of using the one provided by the hardware.
512 - A kernel warning has occurred.
1024 - A module from drivers/staging was loaded.

Comment 8 IBM Bug Proxy 2010-09-17 21:22:11 UTC
------- Comment From hienn@us.ibm.com 2010-09-17 17:14 EDT-------
It passed with snap13 after upgrading firmware to a stable level.

Comment 9 Rob Landry 2010-11-19 15:45:10 UTC
Can this issue be closed, it looks like it was resolved with a later RHEL snapshot + firmware update?

Comment 10 IBM Bug Proxy 2010-11-19 16:03:30 UTC
------- Comment From lnx1138@linux.vnet.ibm.com 2010-11-19 10:55 EDT-------
(In reply to comment #13)
> Can this issue be closed, it looks like it was resolved with a later RHEL
> snapshot + firmware update?

Correct. It can be closed. Thanks.


Note You need to log in before you can comment on or make changes to this bug.