Bug 62647 - Floating panel doesn't hide after menu selection
Summary: Floating panel doesn't hide after menu selection
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-core (Show other bugs)
(Show other bugs)
Version: skipjack-beta1
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-03 18:52 UTC by Graham Cole
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 18:52:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Cole 2002-04-03 18:52:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
On a panel which is set for autohide and contains a menu, the panel will not
hide after selecting an item from that menu.  clicking off the menu to make the
menu disappear also will leave the panel unhidden.  To make the panel hide
again, you are forced to move your mouse over the panel and move it away again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Create a panel
2.  Set panel to autohide
3.  Add a main menu to the panel
4.  Change panel orientation to horizontal
5.  Change the panel position over to the left to change its orientation.  (I
moved it all the way up and to the left)
6.  move mouse over panel to unhide it and select the main menu button
7.  move mouse down to the menu items and select a program or move             
              
       mouse off the menu and click to make the menu disappear.
	

Actual Results:  After the mouse pointer is no longer over the autohiding panel,
the panel remains in view.

Expected Results:  The panel should hide itself after the mouse is no longer
over it.

Additional info:

I found this using a floating panel, not sure if it happens using other panels

Comment 1 Graham Cole 2002-04-08 04:18:15 UTC
This problem seems to be fixed in beta 2.



Note You need to log in before you can comment on or make changes to this bug.