Bug 6265 - Mouse pointer invisible after switching to X
Mouse pointer invisible after switching to X
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-22 15:44 EDT by j.tevessen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 16:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j.tevessen 1999-10-22 15:44:31 EDT
This is a RH60 updated to 61 on an x86. Since 61, after
having switched to console and back, the mouse pointer has
disappeared sometimes. There *is* an reaction to me moving
the mouse (I can see the CPU load go up for a short time),
but a) the mouse pointer is invisible and b) the virtual
desktops aren't switching when the pointer is assumed to be
on the screen's border.

I'm using a PS/2 Intellimouse and a Voodoo3-3000 VGA card.
On RH60, I used a precompiled X11 server with V3 support,
now with RH61 it seems the V3 code has made it into the
std. SVGA X server.

This never happened to me with RH60 and the old X server,
but with RH61 and this server, it happens annoyingly often.
Any ideas?


------- Additional Comments From   10/27/99 10:50 -------

I have the same problem.  The mouse pointer works fine on our Matrox
G400 16MB dual or single headed boards, but the mouse is invisible
on our G200 16MB boards.  The mouse is definitely working.  It shows
up fine on the VGA16(?) server used at the start of XF86Setup.

Hope this helps.
Comment 1 Ian 1999-10-28 04:26:59 EDT
To work around problems with hardware enabled mouse pointers, add:

 Option "sw_cursor"

to any "Device" Sections of your /etc/X11/XF86Config file. This
enables a software drawn pointer, which is slower, but at least
you can see it :)
Comment 2 Preston Brown 2000-02-03 16:49:59 EST
mouse handling has been changed yet again in 3.3.6.  If the sw_cursor option
doesn't work for you, you may wish to try 3.3.6 (or wait for 6.2).

Note You need to log in before you can comment on or make changes to this bug.