Bug 626669 - gtk3 Gtk-3.0.typelib breaks seed calling clutter-gtk which expects gtk2.
gtk3 Gtk-3.0.typelib breaks seed calling clutter-gtk which expects gtk2.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 00:12 EDT by Valdis Kletnieks
Modified: 2011-04-14 18:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-14 18:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2010-08-24 00:12:47 EDT
Description of problem:
Not sure if this is a gobject-introspection bug, a Gtk3 bug, or a clutter-gtk bug. Tripped over this when it broke seed, but I don't think it's seed's fault.
Filing against gtk3 because it owns Gtk-3.0.typelib, feel free to reassign.

% /usr/bin/seed
> Gtk = imports.gi.Gtk;
[object Object]
> GtkClutter = imports.gi.GtkClutter;
GIrepositoryError Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

The problem is that seed calls gobject-introspection, which then goes and looks at both /usr/lib64/girepository-1.0/Gtk-2.0.typelib and /usr/lib64/girepository-1.0/Gtk-3.0.typelib, so Gtk becomes a gtk3 object.  This comes as a surprise to GtkClutter, which was built against gtk2.  There doesn't seem to be any way for seed to specify to gobject-introspection that it doesn't want gtk3.

How is this 2 lines of seed code supposed to work properly?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2011-04-14 18:53:36 EDT
Works fine nowadays.

Note You need to log in before you can comment on or make changes to this bug.