Bug 62670 - 2.4.18-0.4 has troubles with tmpfs
2.4.18-0.4 has troubles with tmpfs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-03 20:04 EST by Michal Jaegermann
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 20:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-04-03 20:04:37 EST
Description of Problem:

With /tmp mounted as 'tmpfs' file system one can see instances of a random
file corruption for files in /tmp.  It is probably the easiest to observe
by doing ./config for a bigger software package.  There are pretty good
chances for strange failures recorded in 'config.log' with obviously
corrupted test sources.  If /tmp is on disk then ./config does not have
any problems.

Mounting /tmp as 'tmpfs' works just fine with various 2.4.9-... kernels.

Version-Release number of selected component (if applicable):
2.4.18-0.4

How Reproducible:
At random.  I noticed that also on other occasions (extra lines show up
in a text file from /tmp re-read into an editor).
Comment 1 Arjan van de Ven 2002-04-04 07:24:57 EST
While I don't have corruption reports for tmpfs in 0.4 I have a boatload of
other "it's broke" ones; this was due to a bad patch and should be fixed in
2.4.18-0.12 and later (rawhide/skipjack SE)

Note: We recommend to NOT use tmpfs for /tmp since it's not a complete
filesystem. Some things will break subtly.

Please reopen this bug if 2.4.18-0.12 or later don't fix this.
Comment 2 Michal Jaegermann 2002-04-04 13:07:00 EST
There is a marked improvement with 2.4.18-0.13 from beta4.  Cannot guarantee
all corner cases but things which were giving me troubles before now work
just fine.

One of possible test cases is 'texconfig' which was unexpectedly aborting
in the middle with 2.4.18-0.4 unless TMP env variable set to some "real"
directory.  Now it runs without any hiccups.

Note You need to log in before you can comment on or make changes to this bug.