Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626765 - The latest F14 ocaml-lablgtk has lower NVR than F13
The latest F14 ocaml-lablgtk has lower NVR than F13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ocaml-lablgtk (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 07:17 EDT by Adam Tkac
Modified: 2013-04-30 19:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: ocaml-lablgtk-2.14.0-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-08 00:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2010-08-24 07:17:17 EDT
Description of problem:
The latest F14 ocaml-lablgtk has lower NVR than F13 because the latest F14 build failed (https://kojiweb.fedoraproject.org/koji/buildinfo?buildID=187388).

Version-Release number of selected component (if applicable):
$ koji latest-pkg dist-f13-updates ocaml-lablgtk
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
ocaml-lablgtk-2.14.0-5.fc13               dist-f13-updates      dwheeler

$ koji latest-pkg dist-f14-updates-candidate ocaml-lablgtk
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
ocaml-lablgtk-2.14.0-4.fc13               dist-f14              rjones
  
Actual results:
F13 package is newer than F14 one

Expected results:
F14 NVR >= F13 NVR

Additional info:
Main problem is that ocaml-lablgtk redefines glib's g_value_{get,set}_variant symbols. I'm not sure if simple removal of those symbols from ocaml-lablgtk sources doesn't cause regression.
Comment 1 Richard W.M. Jones 2010-08-24 07:31:29 EDT
(In reply to comment #0)
> Additional info:
> Main problem is that ocaml-lablgtk redefines glib's g_value_{get,set}_variant
> symbols. I'm not sure if simple removal of those symbols from ocaml-lablgtk
> sources doesn't cause regression.

This came up on the mailing list:
http://www.math.nagoya-u.ac.jp/~garrigue/soft/olabl/lablgtk-list/628.txt
Comment 2 Adam Tkac 2010-08-24 07:50:25 EDT
Thanks for info. Are you going to fix this issue and release update for F14, please, or should I do it myself?
Comment 3 Richard W.M. Jones 2010-08-24 08:23:36 EDT
Please go ahead.

It wasn't clear to me whether upstream had posted a fix or if they
were just saying the fix was 'easy'.  You might want to send an email
to Jacques if you can't find the right patch.
Comment 4 Fedora Update System 2010-08-24 09:41:19 EDT
ocaml-lablgtk-2.14.0-6.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/ocaml-lablgtk-2.14.0-6.fc14
Comment 5 Fedora Update System 2010-08-24 21:23:40 EDT
ocaml-lablgtk-2.14.0-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ocaml-lablgtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ocaml-lablgtk-2.14.0-6.fc14
Comment 6 Fedora Update System 2010-09-08 00:35:43 EDT
ocaml-lablgtk-2.14.0-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.