Bug 626769 - Initscript is placed in wrong directory
Initscript is placed in wrong directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-gather (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks: 633349
  Show dependency treegraph
 
Reported: 2010-08-24 07:24 EDT by Yulia Kopkova
Modified: 2011-12-06 06:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the sblim-gather init script was incorrectly placed in the /etc/init.d directory, causing difficulties during installation of the package. With this update, the init script is correctly placed in the /etc/rc.d/init.d directory, thus fixing this bug.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:56:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2010-08-24 07:24:59 EDT
Description of problem:

According to "Fedora SysV Initscripts [1]" document, initscripts should be
placed in /etc/rc.d/init.d directory. But sblim-gather initscript resides in
/etc/init.d directory.

Version-Release number of selected component (if applicable):

sblim-gather-2.2.1-2.el6

How reproducible:

Always.

Steps to Reproduce:
1. yum install sblim-gather
2. rpm -q --filesbypkg sblim-gather | grep init.d

Actual results:

# rpm -q --filesbypkg sblim-gather | grep init.d
sblim-gather              /etc/init.d/gatherer

Expected results:

# rpm -q --filesbypkg sblim-gather | grep init.d
sblim-gather              /etc/rc.d/init.d/gatherer

Additional info:

[1]
https://fedoraproject.org/wiki/Packaging/SysVInitScript#Initscripts_on_the_filesystem
Comment 2 RHEL Product and Program Management 2011-01-07 10:28:50 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Tomas Capek 2011-07-25 05:09:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the sblim-gather init script was incorrectly placed in the /etc/init.d directory, causing difficulties during installation of the package. With this update, the init script is correctly placed in the /etc/rc.d/init.d directory, thus fixing this bug.
Comment 9 errata-xmlrpc 2011-12-06 06:56:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1593.html

Note You need to log in before you can comment on or make changes to this bug.