Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626772 - guake-0.4.2-1.fc13.x86_64 crashes on startup
guake-0.4.2-1.fc13.x86_64 crashes on startup
Status: CLOSED DUPLICATE of bug 626303
Product: Fedora
Classification: Fedora
Component: guake (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 07:38 EDT by W. Smith
Modified: 2010-08-24 08:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 08:21:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Smith 2010-08-24 07:38:41 EDT
Description of problem:
After installing guake-0.4.2-1.fc13.x86_64 it crashes and generates a traceback.

Traceback (most recent call last):
  File "/usr/lib64/guake/guake.py", line 1353, in <module>
    if not main():
  File "/usr/lib64/guake/guake.py", line 1296, in main
    instance = Guake()
  File "/usr/lib64/guake/guake.py", line 620, in __init__
    self.add_tab()
  File "/usr/lib64/guake/guake.py", line 1137, in add_tab
    final_params = self.get_fork_params(default_params)
  File "/usr/lib64/guake/guake.py", line 1086, in get_fork_params
    self.update_proxy_vars()
  File "/usr/lib64/guake/guake.py", line 1102, in update_proxy_vars
    ssl_port = self.client.get_string('/system/proxy/secure_port')
glib.GError: Type mismatch: Expected `string' got `int' for key /system/proxy/secure_port

Version-Release number of selected component (if applicable):
guake 0.4.2-1.fc13.x86_64

How reproducible:
Always with guake 0.4.2-1.fc13.x86_64

Steps to Reproduce:
1. sudo yum -y install guake
2. guake
3. traceback is generated
  
Actual results:

Traceback (most recent call last):
  File "/usr/lib64/guake/guake.py", line 1353, in <module>
    if not main():
  File "/usr/lib64/guake/guake.py", line 1296, in main
    instance = Guake()
  File "/usr/lib64/guake/guake.py", line 620, in __init__
    self.add_tab()
  File "/usr/lib64/guake/guake.py", line 1137, in add_tab
    final_params = self.get_fork_params(default_params)
  File "/usr/lib64/guake/guake.py", line 1086, in get_fork_params
    self.update_proxy_vars()
  File "/usr/lib64/guake/guake.py", line 1102, in update_proxy_vars
    ssl_port = self.client.get_string('/system/proxy/secure_port')
glib.GError: Type mismatch: Expected `string' got `int' for key /system/proxy/secure_port


Expected results:

guake started successfully

Additional info:

Is there a way to configure abrt (or libcurl) to work behind a proxy?

Guake is great software, thanks!
Comment 1 Pierre-YvesChibon 2010-08-24 08:21:31 EDT

*** This bug has been marked as a duplicate of bug 626303 ***

Note You need to log in before you can comment on or make changes to this bug.