Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626818 - Excessive number of 'kernel: phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 1 (-16)' in messages log
Excessive number of 'kernel: phy0 -> rt2500pci_set_device_state: Error - Devi...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i386 Linux
low Severity low
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 10:02 EDT by Simon Barnes
Modified: 2010-10-30 03:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 07:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Barnes 2010-08-24 10:02:22 EDT
Description of problem:
The /var/log/messages file is continually spammed with the message below.

kernel: phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 1 (-16)

Version-Release number of selected component (if applicable):
2.6.33-149

How reproducible:
Use a rt2x00pci chipset wireless lan card that does not support powersaving

Steps to Reproduce:
1. Install a wireless lan card with chipset using rt2x00pci
2. Configure wireless lan
3. Watch /var/log/messages
  
Actual results:
kernel: phy0 -> rt2500pci_set_device_state: Error - Device failed to enter state 1 (-16)

Expected results:
no such messages

Additional info:

Workaround is to as root run the command 'iwconfig wlan0 power off'

rpm -q kernel
kernel-2.6.33.3-85.fc13.i686
kernel-2.6.33.6-147.2.4.fc13.i686
kernel-2.6.33.8-149.fc13.i686

[root@... ~]# yum info kernel
Loaded plugins: keys, presto, refresh-packagekit, rhnplugin, rpm-warm-cache,
              : upgrade-helper
This system is not registered with RHN.
RHN support will be disabled.
Installed Packages
Name        : kernel
Arch        : i686
Version     : 2.6.33.3
Release     : 85.fc13
Size        : 82 M
Repo        : installed
From repo   : released
Summary     : The Linux kernel
URL         : http://www.kernel.org/
License     : GPLv2
Description : The kernel package contains the Linux kernel (vmlinuz), the core
            : of any Linux operating system.  The kernel handles the basic
            : functions of the operating system: memory allocation, process
            : allocation, device input and output, etc.

Name        : kernel
Arch        : i686
Version     : 2.6.33.6
Release     : 147.2.4.fc13
Size        : 82 M
Repo        : installed
From repo   : updates
Summary     : The Linux kernel
URL         : http://www.kernel.org/
License     : GPLv2
Description : The kernel package contains the Linux kernel (vmlinuz), the core
            : of any Linux operating system.  The kernel handles the basic
            : functions of the operating system: memory allocation, process
            : allocation, device input and output, etc.

Name        : kernel
Arch        : i686
Version     : 2.6.33.8
Release     : 149.fc13
Size        : 73 M
Repo        : installed
From repo   : updates
Summary     : The Linux kernel
URL         : http://www.kernel.org/
License     : GPLv2
Description : The kernel package contains the Linux kernel (vmlinuz), the core
            : of any Linux operating system.  The kernel handles the basic
            : functions of the operating system: memory allocation, process
            : allocation, device input and output, etc.
Comment 1 Stanislaw Gruszka 2010-08-31 16:01:10 EDT
There is no functional problem, only logs are messed up right? If so I could only modify the code to not print massage if device not support power save to fix problem.
Comment 2 Simon Barnes 2010-09-10 06:13:00 EDT
I don't know if there is not a functional problem.

What I did was to add the following lines to rc.local

# configure rt2500pci power mgmt -> off
iwconfig wlan0 power off

This had the effect of disabling the attempt to set the card into power-save mode.

This for me is the preferred solution. Since I do not know if the performance of the card is hindered by the continual attempts to set power-saving mode.

If there is a way to interrogate the card, at initialisation, to see if it supports power-saving mode and then act accordingly that would be the preferred solution.
Comment 3 Stanislaw Gruszka 2010-09-10 07:43:35 EDT
We have a bit similar problem reported upstream. 
http://marc.info/?l=linux-wireless&m=126997977510309&w=2

We have upstream fix for it, not in 2.6.33 nor 2.6.34 kernel.

commit 9655a6ec19ca656af246fb80817aa337892aefbf
Author: Gertjan van Wingerde <gwingerde@gmail.com>
Date:   Thu May 13 21:16:03 2010 +0200

    rt2x00: Fix failed SLEEP->AWAKE and AWAKE->SLEEP transitions.

Maybe above commit helps with that issue too. Can you test this patch or boot updated kernel (for example run F-14 or rawhide liveCD) ?
Comment 4 Simon Barnes 2010-09-10 11:44:44 EDT
I have run this on the Fedora 14 Alpha Live DVD and configured the wireless card.

I observed no messages on device failure being written to the log.

So it looks like the problem is not in F14.
Comment 5 Stanislaw Gruszka 2010-09-13 07:52:14 EDT
We could apply commit from comment 3 to F-13, but there is no certain that it fix the issue and we have easy workaround, so I'm closing bug with NEXTRELEASE.
Comment 6 Stanislaw Gruszka 2010-10-30 03:23:32 EDT
I backorted fix from comment 3 and some different rt2500 fix because other user report a kernel crash caused by these problem (Bug 642031). Fixes are now included in kernel-2.6.34.7-62.fc13 .

Note You need to log in before you can comment on or make changes to this bug.