Bug 626825 - [LTC 6.0 FEAT] 201085:cio_ignore - add wait to s-c-network [NEEDINFO]
[LTC 6.0 FEAT] 201085:cio_ignore - add wait to s-c-network
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.0
s390x All
high Severity high
: rc
: 6.1
Assigned To: Harald Hoyer
qe-baseos-daemons
: FutureFeature, OtherQA, Reopened
: 638965 (view as bug list)
Depends On: 463544 533495
Blocks: 835616 554559 840699
  Show dependency treegraph
 
Reported: 2010-08-24 10:11 EDT by Phil Knirsch
Modified: 2015-03-04 20:20 EST (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 533495
Environment:
Last Closed: 2013-11-12 17:16:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
snagar: needinfo? (pknirsch)


Attachments (Terms of Use)
Proposed patch (488 bytes, patch)
2013-01-25 10:23 EST, Harald Hoyer
no flags Details | Diff
system-config-network-tui_snapshot (11.01 KB, image/png)
2013-08-02 02:11 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Comment 1 Phil Knirsch 2010-08-24 10:12:11 EDT
Cloned to be fixed for 6.0.z.

Thanks & regards, Phil
Comment 2 Steffen Maier 2010-08-26 12:41:08 EDT
Repeating comments of original bug 533495 after it was cloned and closed:

Does that mean, the device.(de)activate member functions were already there but
never called?

> # SUBSYSTEM="ccw" DEVPATH="bus/ccwgroup/drivers/qeth/<SUBCHANNEL 0>" /lib/udev/ccw_init

While this works by accident (ccw_init only uses CHANNEL=${DEVPATH##*/} and does not use DEVPATH any further than to check it to be a non-zero-length string), it is incorrect and misleading, since the DEVPATH given above never exists. First the /sys prefix is missing. Secondly, the ccwgroup will only be there after ccw_init has run successfully, hence this would be a deadlock.

From within udev, ccw_init would be called with:
DEVPATH=/sys/devices/css<X>/<subchannel-ID>/<SUBCHANNEL 0>
Since we don't want to force the user to figure out css<X> and <subchannel-ID>,
the general manual trigger of ccw_init would use:
DEVPATH=/sys/bus/ccw/devices/<SUBCHANNEL 0>
If you really want to restrict it to qeth devices, then:
DEVPATH=/sys/bus/ccw/drivers/qeth/<SUBCHANNEL 0>

Alternatively, the user (and s-c-n) could just trigger the exact same udev rule (/lib/udev/rules.d/81-ccw.rules), that would be triggered on boot or on dynamic addition of devices, and thus trigger ccw_init indirectly without having to know the necessary environment variables:

echo add > /sys/bus/ccw/devices/<SUBCHANNEL 0>/uevent

[http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/ap-s390info-Adding_a_Network_Device.html#ap-s390info-Adding_a_Network_Device-qeth_Device]
Comment 25 RHEL Product and Program Management 2012-07-10 03:39:59 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 26 RHEL Product and Program Management 2012-07-10 21:50:55 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 29 Harald Hoyer 2012-10-12 09:18:42 EDT
*** Bug 638965 has been marked as a duplicate of this bug. ***
Comment 30 IBM Bug Proxy 2012-12-12 15:31:39 EST
------- Comment From chavez@us.ibm.com 2012-12-12 17:10 EDT-------
Hi,
Verified the same in the following build -

[root@xxxxxxxx ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.4 Beta (Santiago)
Kernel \r on an \m

[root@xxxxxxxx ~]# uname -a
Linux xxxxxxxx 2.6.32-338.el6.s390x #1 SMP Wed Oct 31 17:18:25 EDT 2012 s390x s390x s390x    GNU/Linux

This time Using system-config-network-tui, We are unable to configure qeth interface interface. It leads to an error.

Following were the steps followed to reproduce.
a) Installed RHEL 6.4 (2.6.32-338.el6.s390x)
b) Attached the network devices.
c) Ran system-config-network-tui and selected "Device configuration" --> Then selected "New Device" --> then "Qeth"
d) Entered all the device configurations like - Name, Device, Static Ip, Netmask, Read Device Bus ID, Data Device Bus ID and Write Bus ID

e) Finally select the new interface and  select Activate.

f) It leads to the following error and gets hung. - until its explicitly terminated.

[root@xxxxxxxx ~]# system-config-network-tui
An unhandled exception has occured.  This is most likely a bug.  Please save the crash dump and file  a detailed bug report against system-config-network at https://bugzilla.redhat.com/bugzilla
Component: system-config-network
Version: 1.6.0.el6.3
Summary: TB /usr/share/system-config-network/netconfpkg/plugins/NCPluginDevQeth.py:139:activate:NameError: global name 'os' is not defined
Traceback (most recent call last):
File "/usr/sbin/system-config-network-tui", line 335, in <module>
sys.exit(main())
File "/usr/sbin/system-config-network-tui", line 305, in main
if act.runIt(screen):
File "/usr/share/system-config-network/netconfpkg/tui/NCPluginDevices.py", line 182, in runIt
device.activate(dialog = mscreen)
File "/usr/share/system-config-network/netconfpkg/plugins/NCPluginDevQeth.py", line 139, in activate
os.system('/sbin/znet_cio_free; SUBSYSTEM="ccw" DEVPATH="bus/ccwgroup/drivers/qeth/%s" /lib/udev/ccw_init' % hw.Card.IoPort)
NameError: global name 'os' is not defined

> /usr/share/system-config-network/netconfpkg/plugins/NCPluginDevQeth.py(139)activate()
-> os.system('/sbin/znet_cio_free; SUBSYSTEM="ccw" DEVPATH="bus/ccwgroup/drivers/qeth/%s" /lib/udev/ccw_init' % hw.Card.IoPort)
(Pdb)

g) Device are not grouped and hence interface creation fails.

Note :-
What is the intent behind selecting "Activate".
==> Ideally the interface should get grouped and come up in online state right??
Comment 31 IBM Bug Proxy 2012-12-17 08:51:57 EST
------- Comment From targokul@in.ibm.com 2012-12-17 11:50 EDT-------
Hi,

Verified the same in the following kernel version. Issue is not yet fixed. Observation from comment number 38 still holds true.  Issue should be fixed.

[root@xxxxxxxx ~]# uname -a
Linux xxxxxxxx 2.6.32-345.el6.s390x #1 SMP Wed Nov 28 21:09:29 EST 2012 s390x s390x s390x GNU/Linux

Thanks,
Tarun.
Comment 32 Karel Volný 2013-01-25 10:08:12 EST
moving to ASSIGNED as per comment 30 and 31 - the problem doesn't seem fixed
Comment 33 Harald Hoyer 2013-01-25 10:23:20 EST
Created attachment 687520 [details]
Proposed patch

Can you apply the patch to /usr/share/system-config-network/netconfpkg/plugins/NCPluginDevQeth.py and retry?
Comment 34 Phil Knirsch 2013-01-28 09:23:21 EST
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Unfortunately due to the test failure we can't commit to fix this issue in time for the next Red Hat Enterprise Linux update release.

The issue has now been proposed to be fixed for the next update release of Red Hat Enterprise Linux.
Comment 37 IBM Bug Proxy 2013-08-02 02:10:48 EDT
------- Comment From targokul@in.ibm.com 2013-08-02 06:09 EDT-------
(In reply to comment #42)
> Created attachment 76650 [details]
> Proposed patch
>
>
> ------- Comment on attachment From harald@redhat.com 2013-01-25 10:23:20
> EDT-------
>
>
> Can you apply the patch to
> /usr/share/system-config-network/netconfpkg/plugins/NCPluginDevQeth.py and
> retry?

Hi,
Applied the patch to the file NCPluginDevQeth.py by inserting the statement,  import os  as described in the patch. Issue still persists. But the exception (error) message is not observed now.

Following are the observations and steps followed.

1. Installed RHEL 6.4  (kernel version - 2.6.32-358.el6.s390x)
2. Applied the patch.
3. Ran system-config-network-tui and selected "Device configuration" --> Then selected "New Device" --> then "Qeth"
4. Entered all the device configurations like - Name, Device, Static Ip, Netmask, Read Device Bus ID, Data Device Bus ID and Write Bus ID
5. Finally select the new interface and  select save .

Note : There is no "Activate" option. Instead I see Save option. (please find attached screenshot - system-config-network-tui.png)

6. Now It doe not throw any error as mentioned in comment#39

7. But still the devices are not grouped and hence interface creation fails.

Thanks,
Tarun
Comment 38 IBM Bug Proxy 2013-08-02 02:11:13 EDT
Created attachment 781855 [details]
system-config-network-tui_snapshot


------- Comment (attachment only) From targokul@in.ibm.com 2013-08-02 06:08 EDT-------
Comment 39 IBM Bug Proxy 2013-09-19 08:19:19 EDT
------- Comment From targokul@in.ibm.com 2013-09-19 06:38 EDT-------
Hi,
Verified the same in RHEL 6.5 (Kernel version : 2.6.32-415.0.1.el6.s390x). This issue still persists.

Following are the steps followed to verify.

1. Installed RHEL 6.5  (kernel version - 2.6.32-415.0.1.el6.s390x)
2. Ran system-config-network-tui and selected "Device configuration" --> Then selected "New Device" --> then "Qeth"
3. Entered all the device configurations like - Name, Device, Static Ip, Netmask, Read Device Bus ID, Data Device Bus ID and Write Bus ID
4. Finally select the new interface and  select save .
5. But still the devices are not grouped and hence interface creation fails.

Thanks,
Tarun
Comment 40 RHEL Product and Program Management 2013-10-13 21:16:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 41 Andrius Benokraitis 2013-11-12 17:16:22 EST
After thorough deliberation, this bugzilla is not planned on being addressed in the Red Hat Enterprise Linux 6 time frame.

Note You need to log in before you can comment on or make changes to this bug.