Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 626876 - Satellite/Spacewalk upgrade need notes on KS Partitioning change
Satellite/Spacewalk upgrade need notes on KS Partitioning change
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
540
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Martin Minar
Fixed in the 5.4.0 Release - GA'd 201...
:
Depends On:
Blocks: sat540-blockers sat540-upgrades
  Show dependency treegraph
 
Reported: 2010-08-24 11:47 EDT by Partha Aji
Modified: 2016-07-03 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhn-upgrade-5.4.0.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 11:03:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2010-08-24 11:47:15 EDT
As of https://bugzilla.redhat.com/show_bug.cgi?id=593896 we moved the Kickstart Partitioning section of a KS profile from it being commands to a blob in rhnKsData. 
To massage the existing data an upgrade script http://git.fedorahosted.org/git/?p=spacewalk.git;a=blob_plain;f=schema/spacewalk/upgrade/spacewalk-schema-1.1-to-spacewalk-schema-1.2/041-update_kickstart_partitions.py was created. We need to add this to be run to the upgrade notes

We also need to ask the user to backup and delete existing kickstart files in /var/lib/rhn/kickstart/wizard ..
Comment 1 Partha Aji 2010-09-09 16:49:44 EDT
This got ported to the sql stored procs.. So this is no longer necessary.. Just make sure that when  we upgrade the partition commands look ok..
Comment 2 Milan Zázrivec 2010-09-09 16:57:56 EDT
Actually, I'd rather keep this in ASSIGNED for now, since the part about
deleting /var/lib/rhn/kickstart/wizard/* is still not part of Sat5.4 upgrades.
Comment 3 Milan Zázrivec 2010-09-22 12:21:16 EDT
Instructions to delete /var/lib/rhn/kickstart/wizard/* have been added
to preparations.txt document (part of rhn-upgrade package).

satellite.git master: 01457e4728111b2c672faf7f06a1e9565243701c
Comment 4 Milan Zázrivec 2010-10-06 07:38:25 EDT
Correction in instructions to delete kickstart files before upgrade:
satellite.git master: c738f34f5e4c651586bbe6d135432c0017a0f8eb
Comment 5 Miroslav Suchý 2010-10-08 05:04:32 EDT
From preparations.txt:
11. Remove Satellite cache and kickstart files:

Run as root:

    rm -fr /var/cache/rhn/*
    [ -d /var/lib/rhn/kickstarts/wizard ] && rm -f /var/lib/rhn/kickstarts/wizard/*

This is done to ensure cache and kickstart files are recreated with newer
structure after the Satellite upgrade is complete.
Comment 6 Clifford Perry 2010-10-28 11:03:42 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.