Bug 626919 - plymouth-scripts appears to need a requires on plymouth (and coreutils)
plymouth-scripts appears to need a requires on plymouth (and coreutils)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 13:18 EDT by Bruno Wolff III
Modified: 2010-09-01 16:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-01 16:08:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2010-08-24 13:18:07 EDT
Description of problem:
From a livecd-creator log:
  Installing: plymouth-theme-charge        ################### [ 635/1076]warning: %post(plymouth-theme-charge-0.8.4-0.20100723.1.fc14.i686) scriptlet failed, exit status 1

I noticed that /usr/sbin/plymouth-set-default-theme uses 'cat' which is provided by coreutils, though that might not be the command that triggered the problem.

Version-Release number of selected component (if applicable):
It would be the version corresponding to the plymouth-charge version in the error message.

How reproducible:
It's not going to be 100%.

Steps to Reproduce:
1. I found the log in the nightly compose logs at:
http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/logs/20100818.16-i386.log
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2010-08-24 22:53:40 EDT
I looked at this some more and even though it appears there should be a requires on coreutils, in this case coreutils was installed by the time the script was run.
However plymouth wasn't and the script does appear to run plymouth under at least some circumstances.
I don't know under these circumstances if a normal requires is good enough. It may need to be a requires post, since it is being run in a post step (though of plymouth-theme-charge, rather than plymouth-scripts).
Comment 2 Matthias Clasen 2010-09-01 16:08:12 EDT
Should be fixed in plymouth-0.8.4-0.20100823.4.fc14

Note You need to log in before you can comment on or make changes to this bug.