Bug 626946 - don't require perl
don't require perl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 627280
  Show dependency treegraph
 
Reported: 2010-08-24 13:57 EDT by Matthias Clasen
Modified: 2013-04-30 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: tigervnc-1.0.90-0.19.20100813svn4123.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 627280 (view as bug list)
Environment:
Last Closed: 2010-09-04 01:18:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2010-08-24 13:57:32 EDT
To make the F14 desktop spin fit on a cd, we are working to get perl off the image. We just got rid of the last perl dep in syslinux, and now tigervnc-server is pulling in a new one.

If we can't get rid of it, we'll have to kick tigervnc-server off the desktop spin, I'm afraid.
Comment 1 Matthias Clasen 2010-08-24 14:11:52 EDT
Of course, anaconda pulling it in makes that a little harder to do, grr.

So, perl is the 3rd largest package on the live cd, and it is getting pulled in solely for /usr/bin/vncserver.
Comment 2 Adam Tkac 2010-08-25 03:49:48 EDT
In my opinion the best solution is to create new subpkg and ship only Xvnc, vncpasswd and vncconfig there. tigervnc-server will Requires: <this_new_subpkg> so everything should be same for common users.
Comment 3 Matthias Clasen 2010-08-25 10:14:39 EDT
And then anaconda will be made to require only that new tigervnc-server-barebones package ? Sounds fine to me.
Comment 4 Bruno Wolff III 2010-08-25 10:23:45 EDT
It looks like there is a test build of this being put together this morning.
Is there a bug to request the change to anaconda?
Comment 5 Fedora Update System 2010-08-25 10:33:46 EDT
tigervnc-1.0.90-0.19.20100813svn4123.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.19.20100813svn4123.fc14
Comment 6 Adam Tkac 2010-08-25 10:37:53 EDT
(In reply to comment #4)
> It looks like there is a test build of this being put together this morning.
> Is there a bug to request the change to anaconda?

I've just created it - check bug #627280.
Comment 7 Fedora Update System 2010-08-25 22:14:38 EDT
tigervnc-1.0.90-0.19.20100813svn4123.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.19.20100813svn4123.fc14
Comment 8 Fedora Update System 2010-09-04 01:18:19 EDT
tigervnc-1.0.90-0.19.20100813svn4123.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.