Bug 626954 - [abrt] evolution-2.31.5-2.fc14: et_get_n_children: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-2.31.5-2.fc14: et_get_n_children: Process /usr/bin/evolution...
Status: CLOSED DUPLICATE of bug 629386
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:967ca4c8b56cdddd5970fcf08e0...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 14:16 EDT by Will Woods
Modified: 2010-09-21 13:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 13:15:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.72 KB, text/plain)
2010-08-24 14:16 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2010-08-24 14:16:35 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: evolution
component: evolution
crash_function: et_get_n_children
executable: /usr/bin/evolution
kernel: 2.6.35.2-9.ww1.x86_64
package: evolution-2.31.5-2.fc14
rating: 3
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: Switch to calendar view in Evolution
time: 1282673418
uid: 500

comment
-----
crash seems to happen in et_get_n_children, in widgets/table/gal-a11y-e-table.c. This is kind of suspicious:

et = E_TABLE (gtk_accessible_get_widget (GTK_ACCESSIBLE (a11y)));

if (et->group) {
    ...

if (et && et->use_click_to_add && et->click_to_add) {
    ...

Notice that the first dereference of 'et' doesn't check to see if 'et' is valid, but the second does.
Suggest: if (et && et->group) { ...
Comment 1 Will Woods 2010-08-24 14:16:37 EDT
Created an attachment (id=440718)
File: backtrace
Comment 2 Reinout van Schouwen 2010-09-14 03:53:30 EDT
Package: evolution-2.31.5-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open Evolution
2. Press Calendar button
3.
Comment 3 Jeff Raber 2010-09-21 13:15:33 EDT

*** This bug has been marked as a duplicate of bug 629386 ***

Note You need to log in before you can comment on or make changes to this bug.