Bug 626976 - Deluge is not running
Summary: Deluge is not running
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge   
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-24 19:10 UTC by Vaclav "sHINOBI" Misek
Modified: 2011-03-25 19:23 UTC (History)
1 user (show)

Fixed In Version: deluge-1.3.1-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-25 19:23:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vaclav "sHINOBI" Misek 2010-08-24 19:10:55 UTC
Description of problem:
Deluge segfaults after running in classic mode, if classic mode is unchecked, it can't connect to the deamon.

Version-Release number of selected component (if applicable):
deluge-1.3.0-0.3.rc1

How reproducible:
start deluge either in normal or classic mode.

Steps to Reproduce:
1. run deluge in console in normal mode
2.
3.
  
Actual results:
$ deluge-gtk 
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory

(deluge-gtk:6375): Bonobo-WARNING **: Bonobo must be initialized before use

(deluge-gtk:6375): Gnome-WARNING **: Accessibility: failed to find module 'libatk-bridge' which is needed to make this application accessible
[ERROR   ] 20:56:16 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:16 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:17 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:17 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:18 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:18 gtkui:348 Connection to host failed..
[ERROR   ] 20:56:19 gtkui:348 Connection to host failed..
Unhandled error in Deferred:
Traceback (most recent call last):
Failure: twisted.internet.error.ConnectionRefusedError: Connection was refused by other side: 111: Connection refused.

Additional info:
I'm sure it worked in RC2 and I'm not sure when it was broken. I tried to recompile it from src on current system, but no success. ABRT doesn't show anything after the segfault.

there's following error in /var/log/messages

kernel: deluged[6384]: segfault at 20 ip 00007f5c8d3907e6 sp 00007fff51323b30 error 4 in libboost_thread-mt.so.1.44.0[7f5c8d382000+18000]
kernel: Process 6384(deluged) has RLIMIT_CORE set to 0
kernel: Aborting core

Comment 1 Vaclav "sHINOBI" Misek 2010-08-24 20:09:43 UTC
Hmm  the problem is rb_libtorrent. The problem is that when I rebuild it through mock, it still doesnt't work, when it's rebuild through rpmbuild --rebuild the deluge starts to work. So should it be reassigned to the rb_libtorrent or to the boost package?

Comment 2 Fedora Admin XMLRPC Client 2011-03-16 08:12:56 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Update System 2011-03-16 18:54:43 UTC
deluge-1.3.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/deluge-1.3.1-2.fc14

Comment 4 Fedora Update System 2011-03-25 19:22:52 UTC
deluge-1.3.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.