This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 626981 - [abrt] lxpolkit-0.1.0-0.1.20100402git5087383.fc13: Process /usr/libexec/lxpolkit was killed by signal 11 (SIGSEGV)
[abrt] lxpolkit-0.1.0-0.1.20100402git5087383.fc13: Process /usr/libexec/lxpol...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lxpolkit (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/?func...
abrt_hash:83c5e7232e3779bcbdf2e76e135...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 15:19 EDT by Lukas Zapletal
Modified: 2010-08-25 04:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 17:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (25.43 KB, text/plain)
2010-08-24 15:19 EDT, Lukas Zapletal
no flags Details

  None (edit)
Description Lukas Zapletal 2010-08-24 15:19:45 EDT
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/lxpolkit
comment: Crash right after reboot during LXDE startup.
component: lxpolkit
crash_function: IA__g_type_check_instance_cast
executable: /usr/libexec/lxpolkit
kernel: 2.6.33.6-147.2.4.fc13.i686
package: lxpolkit-0.1.0-0.1.20100402git5087383.fc13
rating: 4
reason: Process /usr/libexec/lxpolkit was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282684413
uid: 500

How to reproduce
-----
1. Clean F13 installation
2. LXDE installed
3. Reboot -> crash
Comment 1 Lukas Zapletal 2010-08-24 15:19:48 EDT
Created an attachment (id=440739)
File: backtrace
Comment 2 Christoph Wickert 2010-08-24 15:49:50 EDT
Did you disable polkit-gnome-authentication-agent in the session preferences? Only one agent can be active in a session.
Comment 3 Lukas Zapletal 2010-08-24 17:52:40 EDT
No I did not. Its a standard (GNOME) F13 installation with LXDE post-installation.

It should not segfault definitely but print an error or something.

Idea: Maybe the LXDE rpm could do that for me or issue a warning for now...

Thanks, closing.
Comment 4 Christoph Wickert 2010-08-25 02:41:07 EDT
I agree it should not crash, that's why I forwarded the other crash reports to the upstream bugtracker at http://sourceforge.net/tracker/?func=detail&aid=3032602&group_id=180858&atid=894869
I also added your backtrace for further investigation.

There is nothing I can do on the packaging level, e.g. I cannot echo a warning after installation because install/remove of packages must not be interactive according to the guidelines.
Comment 5 Lukas Zapletal 2010-08-25 04:05:38 EDT
You are right. Well we do have this bugreport at least and upstreamers will hopefully look at it. Thanks for your support!

Note You need to log in before you can comment on or make changes to this bug.