Bug 62700 - RH 7.0 Installer does not use the "enterprise" version of a SCSI Kernel module in a Driver Disk.
RH 7.0 Installer does not use the "enterprise" version of a SCSI Kernel modul...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-04 11:18 EST by Boji Tony Kannanthanam
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 14:20:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boji Tony Kannanthanam 2002-04-04 11:18:59 EST
Description of Problem:
The installer on Redhat 7.0 does not pick up the 2.2.16-22enterprise 
version of a Kernel SCSI module (in this case "gdth" ) included in a Driver disk. It does not use it to 
create initrd image for "enterprise" version as a result one cannot boot into  the "enterprise" 
version of the kernel on RH 7.0 on subsequent reboot after installation. 
The "linux-up" and 
"linux-smp" versions are not a problem.

Version-Release number of selected component (if 
applicable):
Installer (anaconda) included with Redhat 7.0 release.

How 
Reproducible:
Everytime.

Steps to Reproduce:
1. Use the install option "linux 
dd".
2. Choose "custom" install and install "everything"
3. Reboot and choose the default 
"linux" option which is the 2.2.16-22enterprise kernel.
4. The kernel will try and load an old 
version of the driver (in this case: gdth.o ) as packaged with the RH 7.0 install CD and not the 
updated one supplied with the Driver disk.

Actual Results:
Cannot boot using the 
2.2.16enterprise kernel if the RH 7.0 system is installed on a Intel RAID host 
drive.

Expected Results:
Since the 2.2.16enterprise kernel version of the "gdth" driver 
is provided with the driver disk, one should be able to boot using the 2.2.16enterprise 
kernel.

Additional Information:
The driver disk created as per the instructions Doug 
Ledford's Device Driver update devel kit.

The "2.2.16enterprise" version of "gdth.o" 
driver does work. This is verified by booting the system using "linux-up" or "linux-smp" and 
extracting the relevant driver for 2.2.16enterprise from the driver disk and recreating the 
corresponding initrd image, rerunning lilo and rebooting.
Comment 1 Jeremy Katz 2002-04-05 14:20:54 EST
Is there a specific reason you're still trying to install 7.0?  This should work
a lot better in more current releases
Comment 2 Jeremy Katz 2002-04-06 12:45:10 EST
Quote from mail from reporter:

"""It does work a lot better in the current releases.

RH 7.0 is one of the OS versions we support for Intel Integrated RAID and
failure to install under enterprise version was reported as a bug to us. We
are currently using the workaround of manually installing the driver for
2.2.16-22enterprise kernel by using the linux-up or linux-smp kernel. Since
I couldn't see this bug in RH 7.0 errata/support/bugzilla, I put in the bug
report so that Redhat (and our customers) were aware of this bug.

Thanks,
Boji
"""


Okay, closing as CURRENTRELEASE then

Note You need to log in before you can comment on or make changes to this bug.