Bug 627000 - preupgrade (fc13->fc14) fails on encrypted filesystem
Summary: preupgrade (fc13->fc14) fails on encrypted filesystem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-24 20:28 UTC by John Ellson
Modified: 2012-06-02 17:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 17:54:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2010-08-24 20:28:19 UTC
Description of problem:
preupgrade fails to find its install.img after rebooting, probably because it failed to unlock the encrypted filesystem.

Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc13.noarch

How reproducible:
100%

Steps to Reproduce:
1. preupgrade (fc13 laptop with encrypted filesystem)
2. reboot
3.
  
Actual results:
fails to find install.img

Expected results:
a method of upgrading an fc13 encrypted system

Additional info:

Comment 1 John Ellson 2010-08-25 15:00:56 UTC
It's preupgrade from fc13, but this should probably be counted as an fc14 bug since its the upgrade kernel that fails to boot.

Comment 2 Place Holder 2010-09-07 14:24:18 UTC
I am also suffered (am suffering) this bug, trying to move from F13 to F14 using preupgrade.  Is there any damage left behind, or can someone give me the magic incantation to clean up the failed upgrade so it doesn't show up as a boot option?

Comment 3 John Ellson 2010-10-15 19:02:22 UTC
Seems to be fixed as of Fedora-14 TC1.

I successfully upgraded from Fedora 13 with an encrypted filesystem.

Comment 4 Till Maas 2012-06-02 17:54:28 UTC
According to comment 3 the bug is fixed. Therefore I close this bug report. If the problems reoccurs, please re-open this bug or create a new one.


Note You need to log in before you can comment on or make changes to this bug.