Bug 627058 - Path not honored when provided with repo=hd: boot option
Path not honored when provided with repo=hd: boot option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-08-24 20:02 EDT by Tom Horsley
Modified: 2010-09-27 15:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-14.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-27 15:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log after images/ is put under / while another directory specified as boot argument (3.52 KB, application/octet-stream)
2010-08-25 02:14 EDT, He Rui
no flags Details

  None (edit)
Description Tom Horsley 2010-08-24 20:02:17 EDT
Description of problem:

I try to install using the hard disk image technique which has worked for
the past several releases, but it almost always tells me there is an error
finding the install image, or doesn't tell me there is an error, but just
goes ahead and asks me where the image is even though I put the repo=hd...
info on the kernel boot options.

Here's my grub stanza (I've also tried it with LABEL= rather than /dev/sdb2)

title Install Fedora 14 Alpha x86_64
	root (hd0,6)
	kernel /boot/f14x/vmlinuz repo=hd:/dev/sdb2:/downloads/otherinbox/Fedora-14-Alpha-x86_64-DVD/ nomodeset vesa xdriver=vesa
	initrd /boot/f14x/initrd.img

The Fedora-14-Alpha-x86_64-DVD referred to contains just the DVD .iso file
and an images/ subdir where I extracted the install.img file.

I think I may have once gotten it to actually startup anaconda by manually
specifying the path, but I immediately hit the ATI video problem in the
common bugs list :-)

Version-Release number of selected component (if applicable):

Whatever is on the Alpha DVD image

How reproducible:
I've tried booting the above stuff 4 times now, and only had the one time
where I got as far as trying to start the GUI, but then not automatically.


Steps to Reproduce:
1.boot the installer kernel with repo=hd::...
2.watch it fail to find the image
3.
  
Actual results:
constant errors

Expected results:
installer starts up

Additional info:
I think I see a lot of kernel backtrace happening as the boot takes place,
but it scrolls off the screen so fast I can't be sure.
Comment 1 He Rui 2010-08-25 02:09:28 EDT
100% Reproduced. 

I saved the ISO and images/ under /aa/ of my /dev/sda3 and used repo=hd:/dev/sda3:/aa/ as kernel parameter and boot the system. After the error page, anaconda asked for reconfiguring the image path. But I noticed that the default directory was /images/install.img instead of /aa/images/install.img which I specified on the boot command. 

So I put image/ under / of /dev/sda3 and still used repo=hd:/dev/sda3:/aa as boot command. This time install.img was retrieved successfully. When I checked the anaconda.log(see attached), it used images/install.img under / even if I specified /aa.

So I guess the directories specified on the boot command is not honored.
Comment 2 He Rui 2010-08-25 02:14:11 EDT
Created attachment 440838 [details]
anaconda.log after images/ is put under / while another directory specified as boot argument
Comment 3 Tom Horsley 2010-09-10 12:41:22 EDT
I just tried booting off hard disk using the Beta TC1 x86_64 DVD iso
and the repo worked fine with the /downloads/otherinbox/yadda-yadda-yadda
path specification, so it looks as if this is fixed in latest version.
Comment 4 James Laska 2010-09-13 08:53:13 EDT
Matches final release criteria "The installer must be able to use all supported local and remote package source options "

 * https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria
Comment 5 He Rui 2010-09-14 05:38:10 EDT
Verified fixed in anaconda 14.17.1 of F-14-beta-tc1.
Comment 6 James Laska 2010-09-27 15:41:30 EDT
> https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14

A fix for this issue is included, and has been verified, in F-14-Beta.  Closing this issue out.  Please open if the problem remains.

Note You need to log in before you can comment on or make changes to this bug.