Bug 62708 - up2date-2.7.51-7.x.3 - size-avail check not aware of cached files
Summary: up2date-2.7.51-7.x.3 - size-avail check not aware of cached files
Status: CLOSED DUPLICATE of bug 53583
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-04 18:59 UTC by James Manning
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 18:59:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Manning 2002-04-04 18:59:02 UTC
after up2date -u failed (there was enough room to fetch the rpm's but not to 
install them) I freed up some additional space and ran up2date -u again.  The 
basic problem is that the "total size check" @ line 1007 of wrapper.py 
 
    for pkg in selPkgList: 
        totalSize = totalSize + int(pkg[5]) 
 
doesn't factor in whether the pkg is already cached locally or not.  Hence, 
I'm in a situation where up2date says I don't have the room to  transfer the 
rpm's even though they're sitting in /var/spool/up2date/ 
 
At least on first glance, though, whether or not the package is cached on disk 
is so buried that I'm not sure wrapper can easily get that info, but I could 
be wrong - if it's exposable it should be an easy one-line hack to if 
(!cached(..)) it @ line 1008 of wrapper.py, I'd think

Comment 1 Adrian Likins 2002-04-04 21:16:21 UTC

*** This bug has been marked as a duplicate of 53583 ***


Note You need to log in before you can comment on or make changes to this bug.