Bug 6271 - default directory in gnome/enligtenment terminals
default directory in gnome/enligtenment terminals
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-22 17:11 EDT by lrc
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-23 11:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lrc 1999-10-22 17:11:42 EDT
Running Enlightenment/Gnome when I call up a terminal
by doing a right-click on the background, new, terminal
it comes up in the directory .gnome-desktop
[lrc@lrcpc4 .gnome-desktop]$

Since there is nothing of interest or importance here,
this is very annoying.  I have not been able to track
down where this gets set.

I did devise a kludgey workaround by appending the cd
command to the end of /etc/bashrc, so that when
a new terminal is spawned, it comes up in my home directory,
where I would expect it to.

Onc could argue that it should come up in the directory
from which I ran startx, but I haven't figured that
one out yet.
Comment 1 David Lawrence 1999-11-23 11:27:59 EST
The gnome-terminal that ships with 6.1 does not show this behaviour. When right
clicking the root window and choosing NEW->Terminal, it comes up properly in the
current user's home directory.

Note You need to log in before you can comment on or make changes to this bug.